BGE standalone player plays animations laggy or stuttering - game itself is 60fps

Hey i tried to make a game on the BGE and when i tried it out in the standalone player or exported it Keyframe and Texture Animations were played in a laggy or stuttering way, but the game itself ran at 60 fps and i could navigate fluidly through the environment.:(:frowning:

This weird thing only showed up in the standalone player when started out of the blender window or an exported executable.
if i started the game in the embedded player in the blender window all ran just fine even if i maxed the size of the window so it was basically fullscreen.

it is nothing related to messed up settings, because just to test i made a completely new file with the default cube animated with an action actuator in the game engine.

Video example:

My computer is a mid 2011 intel i7 macbook pro with an intel HD 3000 integrated Graphics card.

Does anyone know how this happens and how to fix this?
I’d love you for making my work not for nothing

-M&m

From looking at your video, I think you need to check out these settings:


You’re telling it to use the set animation frame rate of 24 frames per second.
I could be wrong so just try it first.

You should also turn off vsinc as this can reduce your frame rate.

I can’t replicate your problem though, have you tried updating to the newest version of Blender?

I’m seeing a few things;
“Outside” processes seem to be a bit high, so exit some background applications. Also, like Smoking_mirror, your animation framerate is low. The framerate you’re seeing in the profiler is the physics framerate, under the world tab.

I noticed that in the Viewport the framerate dropped to 45 when playing the game, while the embedded shows 60 all the time. Maybe disabling ‘use Framerate’ will solve it. (with vsync on)

This let the game run asynchron and is not a good advice. You will loose control over the timing. This means the game will run with different speed on different systems. This can result in a different feeling.

I know. I was just curious if this would fix the problem. It’s peculiar that frame rates differ so much between two players. If by any chance ‘use Framerate’ is causing this, then you know there’s a problem with it. (I wouldn’t be surprised if it’s a bug).

Restarting my computer did the thing
maybe there was an odd background process from a dumbly ported game from steam, that caused interferences

I always disable the Use Framerate option since it can cause stuttering and other strange timing issues. You should setup your logic on such a way that it is not framerate dependent.

1 Like

I guess this was solved…?

@Moguri - You mean set up motion using a delta time? I thought the physics system is tied to the FPS?

Well, really logic should run, with physics, at a fixed time step :wink:

No friend i think this is good for you got high FPS in all situations.you can manage this level by level of game in same scene i think.