BGE standalone textures not working.

I was messing around with the textures in game engine, and made a simple game for my friend who wanted to see what it would be like. And when i made it into standalone and tested it, the textures didn’t show. I unwrapped them correctly, made it standalone on texture mode (i also tried on material and solid) and i made sure to pack all the textures into the file. And none of that worked. (i even tried doing it on a cube in a new file)
Anyone know if it is a bug with using windows 10 or with the latest version of blender 2.76?
Or do you think im missing something?
Any advice is appreciated.

are you on Multi-textured or GLSL shading mode? specs of the computer in question?

I’ve tried on both texture modes. I don’t really know my computer specs. although i know that it should be good enough

You either need to pack the textures into the blend file using file->external data->pack into blend
Or distribute the textures with the game - preserving the dfirectory structure. Blender stores references to the texture by a relative path, so if you need to keep things together.

I made sure to pack the textures, and like i said, it didn’t do a thing

Maybe the textures are (for some reason) not correctly packed in the .blend file.
Have you tried to put the textures in the same directory? just to be sure, I mean.

I have an issue with 2.76 on WIn10 where the packed textures in my games vanishes, however it is fixed when I switch to wireframe and back to material mode.

Sometimes the texture checkbox might be ticked off, mapping might not be set to UV. Otherwise it might be a bug.

Cool, i will see if that works.

thanks DerpGoose.

Cool, i tried it and it worked.
then i tried packing the files and it didn’t work.

I think there may be a bug with the texture packing on 2.76. Maybe try the 2.77 release or a a build from

I tried putting the textures in the same file i saved the exe to. And the textures show up, so i guess that fixes it.

EDIT: Doesn’t work on other computers though…
Anyone know if 2.77 has fixed it?

Not to be a Necro or anything, but recently i figured out the problem. I was using photoshop images for the game (psd) and the other computers i tried it on didn’t have photoshop, therefore they couldn’t support the image format.
I tested it with png picture format and it worked.

Ok, i must say that is funny! :slight_smile: