BGE Textures


Another noobie question:

When I have models that have textures added and I run the GE I only seem to get the basic colors and not the textures i assigned. They are there when I make a still render image but not when I run the GE. Am I doing something wrong?

I am using 2.5. (Is that the problem? Not part of 2.5 yet?)

You can only use image textures in the GE.

I am using both an image texture (For my ground) and then a blender texture for my water. NOTHING is textured when running the GE.

Make sure you’re in Blender GLSL mode. If you don’t know what that is, if you are in it or etc. do the following:

Click the “Game” tab at the top of the Blender screen. Click “Blender GLSL Materials” from the drop-down menu. I guess that’s a start.

Ok you lost me there. What is GLSL mode?

Go to the “Game” menu at the top of the screen and select the “Blender GLSL Materials” Then switch the draw mode of the 3d view to “Textured” (Alt+z)
Hope this works for you. :slight_smile:

Ok I found the GLSL mode (right side of screen in 2.5 when in game mode) and set it to that.

All I end up with now when I press P is an all white screen…

nearby “object mode” there is a litle window with an icon and if U click in it It opens “Draw type”, choose “Textured”

with this and GLSL mode on, you might see what you want

There we go.

Thank you all so much for you guidance!