BI - Soft shadow of objects is colored. Bug?


When I try to render an object with soft shadow the “feathering” of the soft shadow is always the color of the object’s material.
Is that a bug or a feature?

Hmm…using the Sun lamp out of Blender 2.66 official looks fine. What is your lighting setup?

Attachments


If possible it would be handy to see your Blend file also. Tried with my version of Blender (Latest svn) and couldn’t get it to do that.

Thanks for replies!
It took me a while to find what could be the reason for getting such render.
It seems that enabling Receive Transparent in Shadow panel for the “floor” material to be the cause.
If the cubes are semi-transparent - it looks fine. But when transparency of the cubes is disabled the soft shadows act strange.
It’s definitely a bug :slight_smile:

Verified, you are right.

If you turn on Tangent Shading for the floor material, however, the colorized fringe returns to normal shadow color.

I sent a bug report yesterday and I got a quick reply from Mr. Roosendal.
It seems that it’s a known feature :slight_smile:
So just be careful with Receive transparent and Soft shadows!
@Atom, your “fix” could be useful if the receiving material is OK with this setting. Also Only shadow option gives “normal” shadow too. I suppose extracting the shadow as separate render pass and converting it to BW and recompose will do the trick too.