Big lighting shift in SVN build?

I finally got an SVN trunk build to render (they used to crash consistently), but am not pleased with the differences in lighting from the current 2.45 release:


Much sharper shadow edges, less light scattered into the shadows (or maybe lower ambient), significantly hotter highlights, in general a much harsher image. YafRay rendering, Skydome mode, same settings for both – exact same file, actually.

Is this kind of shift between versions common, 'cause it can really break an ongoing project. I’d like to use the new hair system, but this is a very high price to pay.

And oh yeah, the SVN shaved off her eyebrows :wink:

yes, there are many improvements in lighting for this version. More controls to fiddle with.

There don’t seem to be any changes in controls for Area lamps, can you be more specific? No additions to the YafRay panels either, far as I can tell.

I wouldn’t mind twiddling with controls and adjusting parameters if needed, but the key light (Area lamp) here is maxed at size 100, which should provide much softer shadows, as in the 2.45 release version, unless the nature of Area lamps has been rather drastically revised.

Do you know where there’s any documentation about the changes you describe?

High price?
It’s free!

You’re being either ironic or a bit dumb, hope it’s the former. :wink:

Anyway, seems that Area lights in the new build are somewhat different, though it doesn’t seem to be documented anywhere I could find. To obtain equivalent shadow softness, I had to Scale the Area light up by a factor of around 3 to 5. Contrary to what the Manual says, this doesn’t seem to change the lamp intensity at all, just spreads the light out more (makes sense, given the nature of an Area lamp). The lamp’s Size parameter does much the same thing, but with a max of 100 giving fairly harsh shadows in the SVN build, depending on the scale of your scene (seems Blender’s world scale is geared toward the miniature in terms of parameter limits).

Adjusting around the difference in lighting structure (ambient fill and highlight intensity) has required a fair number of tweaks to both lamp, YafRay, and material parameters.

release notes, search for cubic i think. shadows. blenderdev in wiki. I think broken wrote the changes. I knew a girl once who shaved her eyebrows and then stenciled on this line. wierd.

Too many “Release Notes” floating around, which to look at? Can’t find anything relevant in wiki>blenderdev but may be looking in the wrong place? Searching cubic brings up nothing relevant, lots of hits on shadows but nothing to do with SVN builds as far as I can see.

No biggie, I’ve a handle on a workaround. Thanks anyway!

Oh, and, me, too, in high school, she used a purple crayon or something (really, just hideous), and huge spiky false eyelashes. Yuchh.

Oh, man. Her name wasn’t Mara, was it?

check out this page for release notes,
http://www.blender.org/development/current-projects/changes-since-245/
for the cubic thing, see here,
http://www.blender.org/development/current-projects/changes-since-245/rendering-features/

Thanks, dreblen. Unfortunately there’s nothing in those pages that addresses the change to Area lights specifically. But I do have the Scale fix, actually works well, has lots of flexibility.

But I’ve run into what must be a bug in the most current SVN trunk (Win – rev. 13614). I made some eyebrows for my gal, using the same vertex group as with the earlier build, which is part of the overall body mesh. I assigned the particle system the same material as previously, #3 of a 5-mat multi-mat. With the particle system enabled, none of the Texture channels of the other materials on the body mesh show up at all, not in diffuse, bump, specular, nothing. Only the base RGB and Shader are rendered. If I disable the particle eyebrows, everything returns to normal.

Bummer. :frowning:

@PapaSmurf – no, not that I recall. started with a J, I think. Too many brain cells lost to get the whole name back ;).

___EDIT
Good news, sort of. A previous SVN trunk build I dug out of the Recycle Bin works fine. Must be a bug in the latest only.