Big Problem with Texturing

Hello! I have been using Blender for a while, so i know my was around a bit. I have this big assignment i have to do for school, which includes texturing a 3d portrait. I’m doing it with my friend, so we figure out things together along the way. Now. The problem came with texturing.

I was following this tutorial:

The thing is when i switch to the Texture Paint tab, the object doesn’t unwrap by itself and the object doesn’t turn purple. On the other hand, it worked for my friend, so this is surely a problem in the .blend file itself, and i don’t know how to get rid of it.

We’ve tried:

  • Changing the objects material
  • Creating and deleting new textures, in hope to hook it up with the object
  • Reinstalling Blender
  • Changing texture brush settings
  • Unwrapping the image manually
    the image unwrapped, but the object still wasn’t editable and has not become purple. Plus, the UV
    map looked very weird, it was shaped like a triangle (even though it is a portrait sculpt)

We’ve tried to resolve this issue online, but with no success. Either the issue was different or nobody has encountered it. It may be very close to the “Missing UVs, Textures, detected!” issue, since it displays everytime i try to paint on the model.

I don’t usually psot about issues, but this one i really can’t cope with in any way, since i can’t find any help. I am desperate. So please, if anyone has any idea what’s going on, push me in a direction. Any help is DEEPLY appreciated.

I putting a link up with the .blend files. This is my first time doing this, so if anyone has any issue just tell me.

I don’t really know how to recreate the problem, since the process was really long. New .blend files do not have this problem. Is there a way how to move the sculpt to another .blend file by any chance??

Just copy and paste the object with CRTL+C and CRTL+V to another file when this solves it… I didnt looked at the file but you basically cant texture paint an object? or is this about projection paint? Had several question like that today.

1 Like

I was able to open your blend file and paint on it just fine. I think the problem is that you don’t have a material image you are painting on- I switched the texture painting mode to “Single Image”, created a new image, and then it worked. As far as the bad unwrapping, “Project from View” crashed for me but it looks like it worked right before it crashed. Try those, and see if it works. Good luck!


Yes, i am talking about projection painting. Sorry that i did not clarify.

Thanks man, tried it and worked, im super happy! My friend also tried doing some other stuff which he didn’t specify, but he told me he kept changing the viewport shading, and it like, snapped back to normal…? No clue, he fiddled with it somehow. And yeah, just after i posted i noticed that my unwrapping was completely wrong. I used a seam, then unwrapped it, worked perfectly. I’m new to sculpting so, my mistake there. Sorry for the trouble and thank you once again!

1 Like

no trouble at all :slight_smile: this is an incredible sculpt, good luck on your project!

1 Like