Big seam problem with normal maps

Hello, i made this normal map for my head model, so i wanted to see the result in blender with the normal map applied, but there is a big seam problem

http://img193.imageshack.us/img193/7439/37111402.jpg

the normal map looks like this

http://imgcash5.imageshack.us/img193/2492/ztexture011.th.jpg

http://img193.imageshack.us/img193/2492/ztexture011.jpg

where is the problem here? in zbrush it looks fine in the view port, with the low res mesh and the normal map applied

thank you

could anyone help? does it just look like that in blender or will it also look like that in games?

Have you tried using a tangent normal map ?

Richard

I did set it on tangent normal map, the problem also appears with other my other models like this skull

http://img30.imageshack.us/img30/9750/dfhfshsfhsh.jpg
but when i turn off lights in the Game menu>Blender>GLSL settings, make the texture Col only and not nor, there is no seam
http://img10.imageshack.us/img10/5489/shgsdon.jpg

should i assume that seams will only be in blender?

If you set the image as a tangent normal map you need to export a tangent normal map out of zbrush. Your textures aren’t tangent normals maps.

Richard

I know Blender flips the Green and Red channel with Tangent Space maps, and I just baked a little test that doesn’t quite line up with your results. Try inverting the whole image in Photoshop/GIMP.

I’d like to point out here that Object Space normal maps, like you’ve baked, shouldn’t be used on meshes that will deform, so you wouldn’t be able to animate your head without the normals going crazy.

ok thank you Zwebbie and Richard, i didnt know the difference between object space and tangent space, now i baked with tangent from zbrush, there are no more seams

http://img127.imageshack.us/img127/7720/sdgdsqgsdgsdg.jpg

so for deforming meshes, this is the one right?