Bit of an odd dilemma here

I am a 2D/3D hybrid artist. My pipeline is usually pretty simple- I’ll model something in Zbrush, pop it on over to Blender, UV/texture, light, render, and send it off to Photoshop where I make it look all pretty. This is how I work probably 75% of the time and it’s a great method for single images but I wanted to try something a little different this time.

For my most recent project, I am illustrating a short story graphic novel-style. I got my scene all set up, UV mapped, textured, lit, looks pretty dern close to Photorealitic but that’s not really what I want for this project. I want a more graphic novel appropriate aesthetic, ya know, something that looks more hand drawn. So I figured I’d try out Freestyle. Been hearing a lot about it for a while now and the results look amazing. Also seems more expedient than what I usually do which is to painstakingly draw over every image to make it look hand drawn. So Freestyle seemed like a great option…

…except that it doesn’t work with Cycles and I set all my materials up in Cycles. (sad trombone sound effect)

I’ve never actually worked with Blender Internal before so I have no idea what I’m doing but I can learn. There are plenty of tutorials out there. That’s not the problem. The question is this: Is there any way for me to convert all those materials to BI-able materials while keeping the UV info and textures intact? I would transfer the scene over to Zbrush but the textures won’t go, the GoZ app is outdated and buggy, and besides, Zbrush, despite its outstandingly amazing awesomeness, still, for some inexplicable reason, does not have decent camera control options. I’ rather stay in Blender for this if possible.

Thoughts? Suggestions?

…except that it doesn’t work with Cycles and I set all my materials up in Cycles. (sad trombone sound effect)
How does it not work ? Does it not give the effect you want or nothing at all.
What settings are you using ?

The first thing I saw when I looked up a tutorial on Freestyle was that it doesn’t work with Cycles. It only works in BI which is consistent with my results. Everything renders as black.

The first thing I saw when I looked up a tutorial on Freestyle was that it doesn’t work with Cycles.
You must be looking at a very old tutorial. Freestyle works with cycles

Supply a simple demo blend file that demonstrates the problem

Okay, well that’s good news then. The problem must be that I’m doing something wrong. I wasn’t expecting to have to upload the file so it’s not in an acceptable state to upload. I’ve got the textures in a different folder. If there’s some way to upload the scene and textures without severing the links, I don’t know. If it’s necessary, I’ll just copy everything into a folder, reestablish texture links, and upload it. Is there anything you can offer offhand that might explain why everything renders up black? Or are there any more recent Freestyle tutorials you know of that will be of help?

Oh, when I’m using Cycles, CPU or GPU, it renders up the same as it does even if I don’t have the Freestyle box checked.

“… it doesn’t work with Cycles…” ?? It should.
BI does not change UV maps, in fact you can have BI simple node material and Cycles material in one Node editor window; as a result can choose any render engine.

If your scene renders as such it’s enough to checkmark Freestyle on Render tab to get a simple black outlines.
All what’s left is to experiment and re-render image.
Border render wont work for a preview of line styles you set on Render Layers tab unfortunately- Ooops… It does.

Aye. Apparently, I was looking at an old tutorial. I didn’t realize it works with Cycles. It was rendering up black because I accidentally switched to BI and didn’t switch back. However, trying to Freestyle render it in Cycles, CPU or GPU, it renders without any Freestyle effects.

F12, only key which will give a Freestyle lines. Try on a Default Cube scene.

Trying this… is it supposed to be taking like 15 minutes to render a simple cube and plane? This doesn’t seem right at all. And it’s not working. I suppose I’m just going to have to go through some tutorials but if it takes this long to render a simple cube, maybe Freestyle isn’t going to be an option after all. :\

  1. Freestyle works with cycles.
  2. Freestyle does not take long to calculate with cycles
  3. It works with both CPU and GPU

Basically you check the freestyle checkbox in render tab. Then in the render layers you add a freestyle line set, and you change parameters.

Here is a cycles character I made last weekend that is enhanced with freestyle (very thin lines), it takes ~20 seconds to calculate.

That looks great! Problem is, I have no idea how to get there. Something is going terribly wrong in the process of getting from point A to B. I followed your steps. Seems simple enough. Cube+plane add camera, lock camera to view, check the freestyle box, go to render layers, there’s already a lineset. I hit f12 and instead of being treated to a Freestyle rendered cube, I get an excruciatingly slow render of like nothing. Just for reference, I’m rockin a GTX780 and an i5core processor so it’s probably not either of those things. Same cube was fully rendered in less than a second with plain Cycles.

Here’s a one minute video I made showing the most basic setup for freestyle using cycles.

I followed those steps and I’m still getting an excruciatingly slow render of nothing.

Edit: Maybe it’s something wrong in the render settings? When I render in viewport, it’s fast as lightning but for some reason, when I try to render through a camera, it goes super slow.


wtf.blend (492 KB)

Hmm, you have some unusual settings. To troubleshoot, try downloading this simple blend with my settings, and see if it renders correctly (See image) if it does, you could just use my blend as your default start file, and append things into it, or look through it and figure out which setting(s) to change on yours.

fs blend on dropbox

renders to this:

You are rendering 62,500 samples per tile so no wonder it takes a long time to render. Turn off ‘Square Samples’

Freestyle is a post render effect so you need the whole scene rendered first before you see any lines

Ok, yeah take off square samples, and also you have paused your rendering so it will take, well, forever!

doing that will give you this:

Photox: Yup. That rendered up lickity split. A few seconds, I think. Also, I know it was paused. :stuck_out_tongue: I did that on purpose. I’m not that much of a noob. I paused it because I was multitasking.

Richard Marklew: WOWSERS! I don’t even know how that happened. O__O; In my pipeline, I rarely ever have need to futz around with cameras and the deeper render settings. For my purposes, viewport rendering usually suffices. I can only guess that I must have accidentally entered a wrong number somewhere. I’ll try fixing that and see if it works.

That button should really read Samples^2, I believe many think initially that it deals with a geometric property of keeping samples a square shape or something. At least I did :slight_smile:

Well, I feel like a total derp. That seems to have done the trick. Thanks so much for your help. I didn’t realize FS was a post process and I also wasn’t aware I was rendering at a bazillion samples. Don’t even know how that happened. :stuck_out_tongue:

Still a few kinks to work out and a lot of experimentation ahead of me but I’m happy with the results so far. again. :slight_smile:

The test looks great.

Freestyle does need to communicate with the render engine a bit to get edges data and depth, and there are line style textures that can be used. It doesn’t fully integrate with the rendering/post process, for example mask layers in render layers can’t be used, and it doesn’t care about instanced objects.

Freestyle does render them but uses a lot of memory (thousands of instances = gigabytes of memory), something to keep in mind before trying to do a line render of a junkyard or some gummy bear mountain. Although in those cases it would probably be faster to pick a brush and paint the whole frame with a vomit color (not really a color name, checked).