Bit slow in places

My project is almost done!

Works really smooth, except for one issue…

How it works is you add parts at the console view then in first person view (press C) you can move the parts around. The parts you click and move work fine, but when you move the mouse over parts that snap to the floor (Waterball part for example) it slows right down and judders.

I don’t think its the parts them selfs as it works perfect untill you have mouse over it. It might have something to do with mouse over sensors and scripting etc.

Any ideas how to improve speed, cos other than this issue im getting close to finish.

See http://www.final-lie.co.uk/final_rev_3.blend for part.

The mouse over sensor works based on collisions with the faces of an object. The more collision enabled faces an object has, the more intense the calculations are. For example, one of your objects has 1039 faces. That means when the mouse is over that object, it is checking each face to see what it is colliding with.

You should make invisible lower-poly collision bounds for your objects and and turn off collision on the high-poly faces.

Also, you can gain speed by using a single Mouse Over Any sensor and running a script to check which object the mouse is over and respond accordingly.

Thanks.

Is it possible to t have a single object with some hidden collision faces and some non-collision faces?

This is cos the way the moving and snapping works parented objects do not work at present.

You can select individual faces and check/uncheck collision.

In editmode, select the faces you want to have collision, hit Ctrl-F, select “face mode set,” and check “collision”.

Do the same for ones that you don’t want to have checked and choose “face mode clear.”

-Sam