Bl 2.53 compress does not work?

In the preferences one can switch on (or off) compression and in Bl 2.49 there is a big reduction in needed space. (from about 400 KB .blend to about 50 KB)

In Bl 2.53 SVN 31574 a blend with only the default Cube the saved .blend does not change size with or without compression? (stays around 452 KB)

Is it a bug or something else a missing ‘switch’ in (for self compilation)?

Last time I checked it was working, I’ll do some more tests with recent builds and reply.

are you talking of the old compress in file menu in 2.49

where can we find this one in 2.5

i was looking for this this morning to reduce the szie of a file and could not find it !


Open the preferences (Menu or Ctrl-Alt-U) goto the tab : file second on the right … :yes:

Yep, it does appear to be broken.

I think it has more effect on blends containing image maps.
Just used it to shrink 67meg down to 22meg.
Latest win build from graphicall.

if you only tested it on the default scene, it’s a pretty simple scene, so there may not be anything to compress.

I would suggest you test with a complex scene, instead of the default one.

But see bl 2.49 even with more or less empty screen the effect of compression is a factor of nearly 10 less .blend file? Why not anymore in Bl 2.53?
If ca. 450KB is mimimum … one should know…