Black gradients in 3d view and render.

Ok, so as you can see here in both pics, there are those annoying black edges.

Now, I do know the consequences of using placing two identical parts in a model over the same part in a uv map (which is what I did). So, thinking it may have been that, I made every duplicate area into a new object and applied the same uvmap. Same result though.

As you can see in the second picture, its not a face problem in uvmap. I’ve selected an offending area and you can clearly see those same faces in the uvmap to the right, all right next to each other.

I’ve tried Recalculate Outside.

Any tips to get rid of this?

Also, some random other questions about 2.5 (loving sculpt!)

–> Center view has been changed from C to Ctrl + Numpad something or other (cut off in help menu). Why?
–> Where is area in this version to set laptop controls (i.e. use number keys for numpad?) I don’t have a numpad on my laptop.

C is now ‘Circle select’, a more common sense option than BB. As in earlier versions of blender look in the user prefernces for global system changes.

Have you checked that the edges that are causing the problems aren’t connected to more than 2 faces (Maybe you extruded and canceled by mistake or something like that)

Nope, I tried selecting all the vertices in the problem area and merging them, but all of them said 0 verticies joined.

Here is .blend with the problem area and the UV image.




altair.blend (412 KB)

Sorry, had to bump, I really need to fix this!

It looks like you baked a texture with Ambient Occlusion.

Do you use smooth or flat shading?
Have you used vertex paint?
Do you have more than one UV-map / more than one texture on the same mesh?

EDIT: I checked the model and you have accidentally created a vcol layer, you can delete it in the mesh panel, right next to the UV layers

:open_mouth: Thanks for finding the problem. Unfortunately, I now can’t find where this vcol layer is. What is a vcol layer anyway?

Next to UV Image layer you say?

When I think layers I think the mesh layer thing with the 16 gray squares where you click one and it changes to a different layer. No visual effect though, never figured out what that was. Anyway, it definitely is not what I need. Can you walk me through fixing this vcol problem?

Never mind I figured it out. thanks a bunch!