Black is the new transparent

I’m modeling an eye using Tony Mullens book (Character animation). However, having made the material of the outer layer transparent (alpha 0) and setting ZTransparency to on, the eye renders as black, albeit with a nice specular highlight. The inner eyeball does not show at all. Rendering the inner eye only is fine. Any suggestions as to what I’m doing wrong?

ETA: Problem solved - inner material must be shadeless.

Perhaps you want to turn on TransShad on the interior object? This way it will receive transparent shadows from the cornea (i.e. it won’t be shadowed due the cornea’s transparency), and your eye will still have diffuse shading.

Are you using a lamp as lighting, if so try using a Hemi, or Area light instead