Black line with border render


(Crouch) #1

This is what I do:

  • open blender
  • select the border-option
  • go to camera view (NUMPAD-0)
  • press SHIFT+B
  • select the entire view
  • render

When I do this I get a black line around my image, 1 pixel wide (saving the image and opening it in for example the Gimp makes it easier to see). So in my 800x600 image, there are only 798x598 pixels that are useful to me.
Did anyone else notice this? Is it a bug, or is there a logical explanation for it?

You might of course wonder why one would use the border option for rendering an entire image, and you are right; it’s of no use. But if you wish to render an image in several parts (e.g. 100 parts each with a size of 80x60) and then stick them together again in a grid of 10x10, you will have a black border around your image. So you will have a discrepancy between that image and an 800x600 image you render with the border-option turned off.

PS: I found this while looking for an answer to this question.


(nykysle) #2

It may be the minimum size of the border
If you want the entire image, don’t use border


(Crouch) #3

The Blender Reference Guide doesn’t mention that a border is added.

Border

This allows you to render a small cut-out of the image. Specify a render ‘border’ with SHIFT-B in the 3DWindow (in Camera view of course). A cut-out is always inserted in a complete picture, including any “BackBuf” that may be present.

I even tried accessing it with python, but it only allows to set the bottom left and the top right point of the area that has to be rendered. No talk about border width or anything like that. It’s an interesting suggestion you make though.
Any other ideas out there?


(Fligh) #4

If you select a Border smaller than the camera view, then everything that is outside the border will be black and the border will be like 2 inches thick. If you manage to put your Border exactly on the dotted line (so you can’t see any white; the line turns to dotted red) there won’t be any border.

%<


(Crouch) #5

OK, thanks a lot for clearing that up for me.