Black reflections in Cycles, working ok in EEVEE

I’ve just created a superbasic glossy shader but I cannot imagine why there are that black artifacts on the reflection, notice that they ray amount has been set to 32 so it shouldn’t be the problem.

Any tip is welcome, thanks in advance!

PS. I forgot to say that I have the same problem in Blender 2.79b with Cycles.

Hi. You share .blend file.
Or at least you share an screenshot of the mesh in Edit mode, and your configuration in Sampling and Light Paths in Render tab. Also, Subdivision modifier settings if you are using it.

Unfortunatly I cannot share the model since it comes from a third party commercial collection but here are the edit view and the params

Thank you for your time!

That is the self-reflecting issue as far as I can tell.
So i point you here https://blender.stackexchange.com/questions/24852/black-reflections-with-cycles-glossy-material where a solution is provided

Unfortunatly this happens without normalmaps too.

It happens in our model but also on a smoothed UV Sphere, it seems that it could be the same issue with smoothed normals, any idea on this?

Is it possible to convert triangles to quads in your mesh, and apply subsurf modifier with great subdivision level?
You read in the link that lsscpp has given and search in google about Terminator problem that is common in engines like Cycles when there is not enough geometry.

Edit:
I have tried with this cat:
https://free3d.com/3d-model/cat-95027.html

Converting tris to quads and applying subsurf helps a lot at the edges.
Increasing “Glossy” bounces in Light Paths item helps in other dark areas, but increases noise (Maybe Clam indirect is necessary)