Black screen flashing in edit mode

My sincere apologies for starting this thread here, I figure it probably should go elsewhere but I usually read 'em and don’t contribute much.

My problem is this: when I’m modeling, in edit mode and the limit selection to visible button is on, my 3d window goes all screwy. the background goes black and all the geometry of whatever I’m modeling turns bright red. I did all the usual stuff…reinstalled, rolled back drivers, installed new ones etc but I’ve reached the limits of my competence. It all started on installing Inkscape after watching that great post a few days ago. could be a coincidence I don’t know, and I’ve since eradicated all reference to it on my computer however this small annoyance persists. I would be interested to know If any of you have come across this graphical glitch in the gui, and if so what steps were taken to counter it.

I’ve had the same thing happen when I forced OpenGL anti-aliasing. I did this with the NVIDIA drivers, which allows you to force applications to use certain settings in applications even though they are not really designed to use it, Blender included). I don’t know if that’s really the cause, but I’ve had the same exact symptoms and that’s what caused it. If the wire frame looks really smooth and doesn’t have any jaggies, then anti-aliasing is on.

If you have an NVIDIA card, and are using windows, go to the NVIDIA control panel > Manage 3D Settings, and make sure that the Antialiasing Mode is set to either Application Controlled of Off if the former fails.

Thanks a lot Glen, I’m just reading your response now so I haven’t tried it yet, but yeah I’m using an nvidia card (8500 gt) and running xp and, you guessed it the wire frame looks unusually crisp and smooth today. Wow I can hardly believe it I got a response from the guy that taught me how to use the interface in the first place (you and greybeard a couple of years back) I’m off to check it! And I have a feeling…

Hi, i have the same problem, but i dont know how to resove that thing under linux (ubuntu). I can’t find such a parameter in “sudo nvidia-settings”.

Hi, i have the same problem, but i dont know how to resove that thing under linux (ubuntu). I can’t find such a parameter in “sudo nvidia-settings”.

http://www.cdupload.com/files/30070_wjqq1/Screenshot-NVIDIA%20X%20Server%20Settings.png
http://www.cdupload.com/files/30071_8m7gi/Screenshot-NVIDIA%20X%20Server%20Settings-1.png

but is it possible to use antialising with this video card? in 3d view?