Black spot appearing when viewing certain angles

So, i found something weird… this floppy metal part cover disk, if viewed in this angle, it will produce black thingy. It also appears in my render.

Here’s my shading setup :

my modifiers

so any clue what’s causing this?

Try enabling autosmooth under normals. For a Cycles render, I would also make sure to use anisotropy and UV based tangents for a proper brushed metal appearance.

" I would also make sure to use anisotropy and UV based tangents for a proper brushed metal appearance."

how do i do this? im pretty new with anisotropy thing.

i just enabled auto smooth, still had some blacks.

when i tried to disable modifier bevel, the blacks goes away.


but i kinda need that bevel. hmm…

changing segments to 1 fixes it. Hm, weird, i wonder what’s with 2 segment and up causes this?

Either turn on harden normals on the bevel modifier, or use weighted normal modifier (in some cases harden normals must be avoided, but probably not here). For me, I find it good practice to try with a sharp glossy shader in a HDR world, to see that flat areas remain flat. The black spot is because of the smoothed normal bending the reflected ray so much that it points into the object, terminating the ray.
For setting up brushed metals using anisotropic shading, I place a single point light close to the surface and verify the stretching of the highlight is perpendicular to the scratches. But use UV based tangents, not the default radial one. Ideally you want the edges to have a different material with regular glossy, but I never bother, I live with one surface aligning good and the least important one lining up with the major one - not caring the two least significant surfaces don’t align.