Black spots when rendering

I get these black spots appearing when I render my scene, I was wondering if anyone could help me fix it.


Man I wish there was an one stop shop for the most commonly asked questions… maybe I should make a site like that. Anyway, this is usually do to either doubled geometry, as is common when you make an object and then spin dup it. Go to edit mode, select all faces for those legs by pressing ‘A’ either go to the tools panel or hit ‘W’ for the specials menu and select remove doubles. That should resolve the issue. And it wouldn’t be a bad idea to recalculate normals either, but these are usually overlapping polygons.

Sorry about that, I hate to be the noob that asks all the dumb questions :confused: I did do a search before posting though, and I found a post that recommended the same thing, removing doubles. So I tried that, but it didn’t work. Then you replied and I decided to try it again, this time I selected the whole model and removed doubles and now it’s even worse. I’m not sure how to recalculate normals though, how do you do that?


That’s the next step. In 2.5 while in edit mode hit the ‘T’ button to bring up the tools menu and look for this…


Hit recalculate with all of your problem mesh selected. You can also find this command in the mesh menu in the header, under the ‘normals’ option and you can recalculate inside or outside.

That got rid of most of it, but there’s still some problem areas. I think the problem is in the way I modeled the legs. There’s a lot of disconnected overlapping geometry–it’s a mess. I’m going to just remodeling the whole table and see if I can’t get it right this time.

Thanks for the help. :slight_smile:

No problem. When you get around to remodeling the table, you could end up with the same issues. Just remember the tips above whenever you see issues like this in the future. They are pretty common.

Okay, will do.

if removing doubles, or overlapping faces did not fix the problem, it may be an issue with your camera clipping. try setting your Clipping: Start: 0.100 or higher. i had this problem last week, and i have been using the software for years. so it is not so much a ‘noob’ problem, as one you would not encounter so often, so the fix is less obvious. apparently a clip start of ‘zero’ value causes some calculation errors.