Blander 2.73 does NOT export 3ds WITH textures!!

I have having problems with trying to export 3ds images WITH textures!! it DOES NOT attach textures into the exported 3ds model!! I renamed the textures to be ONLY 1 character long and HAVE then in the SAME folder as the .blend file, as mentioned elsewhere on this forum and elsewhere but STILL NO textured 3ds file!! how do I fix??

Tested with 2.73
Added a texture to an object mapped to UVs.
Exported a.3ds file.
Texture located in same directory as .3ds file.
Started a new blend file.
Imported the .3ds file
The texture was still correctly mapped to the objects UVs

Ensure the texture file is named in the correct format
Example: ensure the extension is named .jpg and not .jpeg

they ARE!! if i use the original textures that came with the .blend I downloaded, they render properly in Blender but DO NOT export in 3ds!! If I move them from /textures folder and/or give them an 8.1 file name, the model DOES NOT render with textures in blender nor export with them! these are .blend and png textures from here:

Tried one of those files
Exported as .3ds file and imported back into blender. The result is shown below

Changed the texture names so were not too long and put in the same folder as the .3ds file

Attachments (47.8 KB)

it is STILL NOT working for me! (at least for the Xerneas one) :frowning:

Upload your blend file just before you export the 3ds file, the exported 3ds file (ensure you pack all textures in the blend file from the File / External Data menu before you save it.


what do you mean by “upload your blend file”? idgi

I don’t get why every help forums on the internet ditch me and leave my topic unresolved!! :frowning:

Save your .blend file, upload it to this site and tell us the download link. I need to see what you have

Ensure the texture file is named in the correct format

If I recall correctly, texture names should be 8 digits the most (3ds). Am I right?

it will NOT accept my file

Not a valid file
so I uploaded it elsewhere

No one is going to download your mediafire link. Unzip the file and upload the .blend directly to paste all. In Blender, select File and pack your textures before uploading.

Downloaded your file and opened the XY_Xereas.blend file. All the textures that are used in the materials have invalid names (too many characters as indicated previously). These texture files were renamed to make them shorter and those new textures reselected for each materials textures. So now the blend file is using materials which are linked to these renamed image textures.

Then the file was exported to a .3ds file and placed in the same directory as these renamed textures. This .3ds file was re-imported into blender with the result below (the images show correctly)

So to summarise, as stated from the start the image textures are invalid for the .3ds file format (too many characters) so rename them and ensure the materials in your blend file are using these renamed files. Don’t just rename the source images as blender will not know you are using these new files, it will still be looking for those original long name files.

which I don’t know how to as your original link will NOT allow zipped files

and the ones renamed A1.png A2.png etc?

If you renamed the files did you update the materials in your blend file to point to those renamed files. If not it will still be looking for the original long name files which the .3ds file will try to use but fail because their names are too long

You need to start with a basic understanding of how materials are used in blender and how textures are used. I suggest you do a search on youtube for some beginner blender material tutorials.

Why do you need such a rubbish format as .3ds anyway ?

My blender shows NO textures AT ALL!!! my Blender looks COMPLETELY DIFFERENT than yours and I eventually found the textures list, but NOTHING is there!!! NO preview of the model in the user perspective either!! what is wrong?? render image works

it’s the only thing sketch-up and Sim City 4 recognizes

Do the textures show up in the materials panel ?
Are you in textured or material view mode ?

it’s the only thing sketch-up and Sim City 4 recognizes