Blank preview screen #3 - follow-up post - please append to previous

So, in my previous post, I mentioned that version 2.78 behaved normally when I started a new project from scratch. I could add a “movie” and it would display in the preview screen. Obviously, there was something wrong with such that the previous project, assembled in version 2.68 was not working in the new version, and I assumed the problem was that the new version could not find the location of the elements in the project. So, I did a search on locating missing clips in Blender which quickly put me on the right track. However, for the life of me, clicking external data and find missing clips, I could not navigate to the drive/folder containing those elements. Seems a common problem for me in Linux with several different applications - some of my drives seem almost impossible to find from within the application. They show up when I click Ubuntu’s file icon/other locations, but I cannot navigate to them from within the application.

I finally tired of this frustration, and, instead, browsed from Ubuntu to those folders, copied all the elements to a folder that I created on the desktop, and that solved the problem for all but one video strip which refused to cooperate. I could see the file from Ubuntu, I could navigate to it from Blender/external data/find missing clips/, but clicking to actually find missing clips would not work for this clip, so I set the green cursor at the beginning of that clip, selected the clip, deleted it, and added it back from the desktop location where I had moved everything. That seemed to have worked, but now, when I click play, the entire project moves in slow motion.

I assume that this has something to do with the proxy settings, so I re-set proxy to 25% and made the same selection in the preview properties window (if that’s what you call the box at upper right). No joy so far.

I will do a search on this problem to see what I find.

Hoping to see my posts make it to the board soon.