Blend4Web : fast preview and project manager are non-functional

Not sure if this is the appropriate place but I couldn’t find a suitable category.

I recently discovered the Blend4Web add-on for Blender and it’s mainly been straightforward to use. I have no problem exporting to html and manually opening the files, but neither the fast preview nor project manager appear to be functional. The lack of fast preview is annoying as I have to keep generating html every time I tweak a setting, but the lack of project manager (as I understand it) prevents me from exporting to JSON, which is necessary if I want to include physics.

I’m running Blender 2.79b with Blend4Web 18.05.0 SDK on Windows 10.

More specifically : If I press the fast preview button, Blender completely freezes (no functionality, window greys out) for an indefinite period - I’ve tried waiting for over 10 minutes but nothing happens. No error messages are displayed. Similarly, if I try to access the project manager, a browser window opens to http://localhost:6687/project/ but it just perpetually says “loading” in the window title and nothing ever actually loads. The same happens if I try the “SDK Index” button.

If I access the “index.html” file from the installation directory, I see a page telling me that WebGL is available but the development server is not available. From here, the “project manager” link tries to open c:/project, which does not exist, and “code snippets” similarly accesses a location which does not exist (file:///C:/apps_dev/code_snippets/code_snippets.html). Both show a page with a “file not found” error.

In the Development Tools section of the Scene panel inside Blender, it says the development server is running. If I stop it I get the error 2716, but then I hit Stop again and it stops. If I then restart the server, then the project manager button does nothing at all - I can click it and Blender doesn’t hang, but no window or tab opens. The Fast Preview button behaviour is unchanged, i.e. Blender hangs.

Could this be an installation problem ? I set up the scripts directory and activated the add-on as per the installation guide. Initially I had it on a different disc, but I tried moving to the C drive with no effect.

Any help appreciated !

How did you set up the installation path? Verge for example needs it to run properly. I believe B4W needs it too.

Also you might want to ask @AlexKowel about it. He’s a former programmer of the latter and currently involved in the former, so he might give you pointers on Blend4Web and on Verge3D.

Thanks for the reply ! I tried using various different installation paths but nothing worked. In the end I’ve resorted to using Verge3D, which installs and runs with no issues even though the setup is very similar. No idea why Blend4Web has issues, but I guess Verge3D is a better long-term solution anyway.

Hm. The installation path should be free of spaces, german s, german umlauts and signs. So only a-z, A-Z, 0-9, dash and underscore.

Anyway. I’m glad that you figured it out for Verge3D, even if that means a different software and payed licences. I do think that it will be the better longterm option too. Just as a sidenote: maybe take a peek at armory game engine.