Blender 2.36 mirror reflection bug?

Hi guys,
I am new to Blender and I love it.
When the new version 2.36 came out
yesterday, I installed it righ away.
It seems though that I am doing someting
wrong, because mirror reflection is working
in 2.35 and not in 2.36.

As an example, I had a cube over a plane.
The plane is set up from a mesh plane, and
the new material properties as set up with
ray mirror on with 0.4 Ray Mirror. The lamp is
standard spotlight, render is internal blender
with shadow and ray on selected.
Version 2.35 gives the proper reflections,
the same file with v.2.36 has no mirror
reflection of the cube on the plane.

I am running it on Windows 2000,
overinstalled 2.35 with 2.36 but didn’t
re-install yafray.

Once I removed both v.2.36 and yafray and
reinstalled the old 2.35, the same file
worked fine, and got back the mirror

Any ideas about what I shall do
differently in V.2.36, or if it is a bug
in the new release.


it could have simply been an instalation error. works fine for me, in both blender and yafray. Another problem could have simple been that the error was in the 2.35 version.

And another thing, you dont have to reinstall yafray, every time you upgrade the blender version.

hope this helps

:stuck_out_tongue: cotokid :<

i found the problem, if you tampered with the octree resolution, then tried moving back down to 64, it will not work. try moving it up to 512 then tell me what happens.

:stuck_out_tongue: cotokid :<

Thanks for the feedback.

I installed v.2.36 on my Win.XP
and it seems working fine.
I don’t understand what went wrong
on my work computer (Win2k).
I am running an animation which
will take about a week :frowning:
(180 frames, 1hr/frame), then
I’ll try to reinstall the new blender
and see again if it works on that as well.

Thanks agin for your help,

You’re giving a lot of great advice for a newbie and for someone not seeming to know too much about Blender. You pretty damn DO have to reinstall the current yafray version after upgrading blender.

i had rendering errors when upgrading a previous version of blender a while back.

It might be a good idea to uninstall your current blender and install the new one so older files don’t get overwritten
after doing that, the problem I had was no longer there

make sure to back up you .blend file and possibly your folder with scripts (for instance, fiber isn’t shipped as a plugin in the official blender version (yet… maybe someday)


OK guys,

I am still lost a bit.

At home on my Win XP, Blender v.2.36 is working fine.
At work on my Win 2k, V.2.36 does not give me the
shadows on the plane from my original model file. I can create
a new model (simple box over a plane), and that seems fine,
but in my old complex model, even if I remove the plane and put in a new
one under the model, the shadows are not showing up.
(they are ok on the model’s individual parts though.)

When I reinstalled the old v.2.35a under Win2k, my model worked fine.
(shadows on the plane that is)

I also tried to un-install the old version, remove the
blender and yafray directories, even removed the references
from the registry, and reinstall both from scratch, still not working.

I may have to stick with the old version on Win2k
and use the new one on XP.

Also, lately yafray crashed for no apparent reason.
Very strange. I don’t know if it is from the numerous
installs-uninstalls, or just I am duing something dumb…

My final pain is that when I yafray a glass object,
the shadows are there, but they don’t pick up the
color from the glass. Thay just look gray on the plane.
I even tried to add the photon light, bumped up
the number quite high, took a long time to raytrace,
but still no color in the shadows. Any ideas?