Blender 2.40 SVN now also requires Python 3.1?

Hi everyone,

I checkout and build blender SVN for 2.49 almost on a daily basis (with python 2.6.2), but ever since yesterday when trying to build I got an error saying it required Python 3.1.

So, has blender’s 2.49 source also moved to using Python 3.1 as default?
Finally, I uninstalled my previous version of python and installed the newly required one, but when trying to build with scons I get the following error:

File "scons/", line 66, in <module>
    if os.environ.has_key("SCONS_LIB_DIR"):
AttributeError: '_Environ' object has no attribute 'has_key'

So no chance to build blender :frowning: Has anyone else gone through this already?

To make things worse, if I succeed in compiling blender, this will also make it incompatible with Yafaray. :frowning: Python 3.1 builds will be required.

I guess this is one of those “major steps ahead” blender is taking, but the transition to achieve it is usually traumatic (in terms of errors generated and changes to be done). :wink:



Blender 2.4 is no longer in trunk.

Read this email for details:

Since you already updated to 2.5, you’re probably better doing a full checkout of the 2.4 branch, it should be faster.

svn co


Yes, and when you succeed in building it, it will be Blender 2.50. I had a similar experience recently:-

Blender2.50 is now the main trunk and 2.4x is a branch. I checked out a revision of 2.49 around r23140 and it still works fine(built with Python 2.5 on Ubuntu 8.10).

It was a disappointment though, and it took a couple of hours to figure it all out…

EDIT - Gah, beaten by a mod… :slight_smile:

Cool, thanks a lot guys, good to know. :wink: I’m glad things are pointing towards a 2.5 release now.
Also, many thanks for the 2.4 branch info.


ps. Final question. I’ve been checking out 2.5 on Linux and compiling it without problems, but is there some updated info on how to do the build properly in Windows?