Blender 2.49 Bump maps do not show in GE

Hey everyone! I’m still quite green when it comes to Blender as we only spent one year to study it at the university. And I tried to search for the answer on the internet with no success.

I have a simple test scene set up with two characters in a simple room. Both characters have UV mapped diffuse, specular and normal maps applied. They all show up fine. I don’t really know how to use specular maps in Blender so I’ve just set it to play the role of bump map by using ‘yellow’ Nor in Map to. The bumps show up fine when I render a simple screenshot but do not when in game engine. I have GLSL materials enabled and using Blender 2.49 version.

Here is what I’m talking about. Left - screenshot render, Right - game engine

Could anyone help me with this please? There must be some tiny annoying setting or tick-box I haven’t tick or something:D:D

I think that bump maps don’t work correctly (they might, but I believe it’s slower than just using a normal map). It’s easy to convert a diffuse map into a normal map - GIMP has a plugin (that’s included, I think) that converts RGB images to a normal map fine.

I think the map is not the cause of the problem. I have exported my Troll model into 3ds Max for animation and used the same set-up with Specular map acting as a bump map.

I think I just used wrong map settings in Blender.

If somebody who managed to run bump maps in 2.49 game engine could you please explain to me how to use them correctly?:slight_smile: I would really appreciate it!


Do you mean that you want to use a grey scale displacement map as a normal map in the GE? Bump map is a generic term that means something different to most everyone - some people call normal maps bump maps. I can’t say that I’d recommend that technique (if indeed it’s what you are trying to do), over a normal map. Using a normal map will give you the results you want, without any trouble. You can also use a spec map in a separate channel - spec maps are funny in 2.56 - you have to use Intensity, Color and Hardness, or they don’t seem to work. Another quirk is that the main spec slider in the material settings still affects the spec. It’s a bit messy.

If you look at my two screenshots in my first post you can see what I mean. The one on the left has normal as well as bump details show on the models and the environment. My normal maps are the usual blue/violet normal maps I’ve baked in Blender. Then I’ve also created a specular greyscale map from the diffuse map so I can use it as an additional bump map as well as specular map. The normal screenshot render shows these details.

But when I go into game engine only the normla map shows up. so the models look really smooth. There is no skin detail whatsoever. How would you use a greyscale bump map in 2.49 so it will show up in GE? Thanks!

I think you are not understanding what we are saying. Just convert the bump map to a normal map and it will work. Yes, I get that you have an overall, big geometry normal map. Create a detail normal map from your bump map and it will work. You can then bake the two together, so that you don’t have to add a new map. The point is, I don’t think greyscale images will work as normal maps in the GE. I will try.

Interesting. It seems I was wrong, at least in 2.56 (I can’t say concerning 2.49). A greyscale bump map will work. Simply map it as normal, however, don’t tick normal map under the image sampling tab. Just use the normal slider.


ow right I see now! Thank you for your suggestion! I’ll try it now!:slight_smile:

It works, but looks kind of crappy (greyscale bump). Blender seems to put a geometric pattern on it…like a low quality .bpm file (dithering?). There is a new set of buttons in 2.56 under the influence tab “Bump Mapping”. Quality makes it a bit better. Interesting. Learned something new today…doesn’t work well enough to use, but it seems like a work in progress for blender.

Edit: I still recommend baking the two normal maps together. That makes for a very nice effect.

Just followed your suggestion and converted my greyscale bump map into normal map using NVIDIA Photoshop plug-in! then combined the two together with overlay blending option. and it WORKED! You just made my day man! I should have come here sooner to seek answers!:slight_smile: Thanks so much!!

Cool, glad to have helped, and I learned something new. Nice monsters!

Edit: By the way, I’ve used the nvidia plugin for years, but lately I’ve been using njob. It seems to make more “alive” normal maps, because it has a diffuse to height, height to normal step. Play around with the two, and experiment. It seems to work better.

Awesome! Thank you very much! I’ll give it a try!:slight_smile: