Blender 2.5.3 Box Select and vertices issues!

Im having some real issues in Blender 2.5.3 with simple actions such as selecting vertices, particularly the box select tool… Im going to try and add some screen shots soon to show you what I mean.

As an example:
Simple UV sphere. Use the box select tool to only select half of the vertices. The selected vertices that are highlighted are actually scattered throughout the sphere and are definately not the ones selected.

I am also have issue where I select one vertice and another one (sometimes not even a close one) is highlighted.

Definately not an issue with other applications I am running as I do not have this issue with alpha’s or blender 2.49

anyone else experiencing this…

Using Blender 64 bit installer
on win7, i7920, 6G ram

What video card and driver version do you have?

Also have you tried the various drawing methods available in the user preferences panel, also try testing with VBO’s turned on and off, lastly make sure you don’t have AA enabled in your video card’s settings panel.

EDIT: Also, can you check with hide back faces option turned on and off (it’s next to the face selection options). I sometimes have issues with it randomly selecting a few faces when it’s turned on, when it’s turned off however, it usually works fine.

I have had the same problems before with blender, but normally after use for awhile would I get the problems… and at small different camera angles I would get odd selections like you are having.

Found it best to use the box select when in Orthographic View, in Persp at times can be really hard to select… also it sounds like you have had “Limit Selection To Visible”

Not sure if this will help if it a big bug or not… but I have had these problems before on blender builds in Persp_views even trying to just select one Vert at a time…

Hope this helps you and others…

Daniel8488 is correct. I had the same problem with an NVIDIA card and fixed it by setting AA in the control panel.

Thanks for the responses - I have Nvidia GTS250 1G - I will get into the settings and make some adjustments and see if that works.

I have the same issue as hevjodo reports. I am running Windows 7 Professional, 64-bit. My graphics card is a Quadro FX 3700M, nVidia Driver version 188.40.

I have found two ways to work around this feature that both work:

  • Disable AA in the nVidia Control Panel
  • Disable “Limit selection to visible (clipped with depth buffer)” in Blender 2.53

BTW: I find that if I enable AA, and enable “Occlude background geometry” in Blender 2.49, I DO have the same issues there. However I have not noticed this before, since in 2.49 “Occlude background geometry” is disabled by default.

Hi, I can’t find the AA option. I have entered the NVIDIA control panel and then “manage 3D-settings” (I think that would be the corresponding English option, since my windows Vista is in Swedish).

Now I’m able to select options for certain programs… Am I at the right location?

EDIT

ForceWare version: 175.56
GeForce 9600 GS

(Windows Vista)