Blender 2.5 A0 64 crashed - will no longer open - ubuntu

Hi.
I hope someone can help me out.

I was using blender 2.5 64 bit today on my ubuntu machine. It crashed and I restarted the system.

Now Blender 2.5 64 will not open.

Any suggestions?

EDIT: I’ve downloaded a new 64 bit build from graphicall which works.
Downloading new versions from the foundation and replacing the existing version doesn’t work.

Thank you

Weird!

I’d have thought the .b25.blend would have become corrupt, but if other builds work then that can’t be…

Why not just use the new one that works?

I’ve got the same problem. I’ve installed Ubuntu 9.10. Oddly enough, all Blender 2.5 alpha builds don’t work in Ubuntu except official one.

BTW, I am new to Ubuntu.

Why software has privileges to corrupt and restart OS during error? Aren’t they supposed to run in sandbox? I have no idea what kind of malicious software it must be to cause any modern (since 2001) and properly installed Windows version to get BSOD on software error and making unable to close the tread using task manager. This kind of problems always makes me think that Ubuntu is way too far from being as stable as Windows. And taking into account that Xorg is not part of system kernel and tends to freeze GUI in moments of extremal CPU usage, it just depresses me and makes me feel like WTF guise it’s 2010s make your system stable. Srsly, I’m afraid to use Ubuntu for production work since I’ve got these problems happening just like twice a week.

Not for software that run in kernel space, like drivers, which is most likely the case here.

Martin

Where would I find the .b25.blend file?
I’m using the build that I downloaded but it seems to have problems. Ctrl-N, Ctrl-Q crashes it for example.

I too am pretty new to Ubuntu.

I had the same problem…

Deleting the startup file B25.blend or .B25.blend (can’t remember which) in the home directory solved it for me.

I’ve got the same problem. I’ve installed Ubuntu 9.10. Oddly enough, all Blender 2.5 alpha builds don’t work in Ubuntu except official one.

Your problem seems different. Try executing those builds from a terminal to see some error messages. Might be caused by missing library dependencies.

Thanks man. Some missing library dependencies caused this problem. I solved it installing the following packages:

libfftw3
libopenal.so.

:yes:

How do I do that?

I’ve cd to the directory but when I type blender it opens the installed 2.49 version.

EDIT: I dragged and dropped it and I was given this error

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: can’t initialize sys standard streams
ImportError: No module named encodings.utf_8
Aborted

To execute it from terminal…

cd /path/to/blender/

Then,

./blender

I think u typed just “blender” which executed what you had in your bin directory (the installed 2.49 version).
Also try:

./blender 1

As for the errors, im not sure, but this is how you add $PYTHONHOME:
read all before doing


gedit ~/.bashrc

and in the editor, go to the end and add:


export PYTHONHOME=/path/to/python/installation/

save, close, and reboot.

Before trying to set PYTHONHOME,

sudo chmod 755 /usr/local/lib/python2.4

Change the python version to what you have.

I have no idea where python generally gets installed on Ubuntu
Is it /usr/local/lib/python
Software center tells me I have both python 2.6 and 3.0 installed

I entered in terminal

sudo chmod 755 /usr/local/lib/python2.6
sudo chmod 755 /usr/local/lib/python3.0

But I haven’t done the rest yet

I cant even get 2.5 to compile in Ubuntu anymore. I have been compiling blender in linux for the past few years now. Not even with a fresh install of Ubuntu can i get it to work.
Ubuntu 9.10 64bit desktop edition.

Maybe you want the post the last error message.

How do I do that?

I’ve cd to the directory but when I type blender it opens the installed 2.49 version.

EDIT: I dragged and dropped it and I was given this error

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: can’t initialize sys standard streams
ImportError: No module named encodings.utf_8
Aborted
Did you tried removing/renaming .B25.blend?

I don’t know how much do you know about linux, but just in case:
In linux, files that start with a dot are hidden. To see them, check: View -> Show hidden files, in the file manager’s menubar. Rename .B25.blend to .B25.blend.old, you should find it in your personal folder.

Then open a terminal and execute blender25 as rp181 said, with ./blender to make sure it executes blender from the current directory.

When you execute blender this way still gives you the same error?

Other config files that may cause problems if get corrupted are .Blog and .Bfs, try renaming those too.

If this build used to work for you, you shouldn’t change PYTHONHOME and that kind of things…
Blender 2.50 requires python 3.1 and it is bundled with it, so it should always find it.

I cant even get 2.5 to compile in Ubuntu anymore. I have been compiling blender in linux for the past few years now. Not even with a fresh install of Ubuntu can i get it to work.
Ubuntu 9.10 64bit desktop edition.

Try following this instructions:
http://wiki.blender.org/index.php/Dev:Doc/Building_Blender/2.5/Linux

Cool,
The instructions I was following has been updated! Thanks JMR they even have some fedora instructions too.

There wasn’t a file named .B25.blend in the dir even when I pressed ctrl-h.
It is there now though, but doesn’t fix the problem when deleted or renamed.

renaming the .Blog and .Bfs didn’t help either.

I was running blender in fullscreen mode when it happened. It crashed. Atleast the computer was not responding, so I shut the power off. Then I started it up again. Then blender wouldn’t load.

I did download a new build but it is a poor build with problems I would love to have the official build working again.

Is there a way to repair Ubuntu?

I’d rather not… but should I just re-install the OS?

I removed python 3.0 should I install it again?

In your first post you wrote:

Downloading new versions from the foundation and replacing the existing version doesn’t work.
Instead of replacing, first remove the previous 2.5 version and then install the new. Probably you did it that way, but just in case…

I am assuming that you are using Blender 2.5 alpha 0 downloaded from Blender.org

I still don’t think that this is an ubuntu problem…
And don’t reinstall, at least not yet.

Try this: create another user account and login with it, then unpack Blender2.5 (don’t copy the folder you are using now) and execute it to see if works… If a new user with a clean Blender still gives you the same error then is probably an ubuntu problem.

If still doesn’t work, cd to the blender 2.5 directory and run Blender this way:


PYTHONHOME=.blender/python ./blender

Shouldn’t work, but just to discard it.

Finally, you can install python 3.1 (instead of 3.0) and Blender will probably open, but it won’t work as well as it used to with its own python version.

Sorry Dude.
I’ve got contracts that I’ve got to finish so at 2pm today I reinstalled Ubuntu.
If it happens again, which it probably will, since I have a knack for this sort of thing, I’m definitely going to try what you’ve suggested here.

I guess I should have waited longer, but the other builds from graphicall just weren’t cutting it.

Never mind that I could have booted into windows on another drive…
I just hate windows…