Blender 2.5 (emit but no radiosity?)

It seems you can use subsurf’ed vertices instead of subdividing your original mesh.

Though I wonder how density of vertices is related to color bleeding effect. How much you need to subdivide your mesh in order to get nice color bounces while maintaining vertex count as low as possible?

So, does this require a special build? I am using 2.5 alpha and I see no effects when I render these attached blend files? How do you activate this AAO?

It works for me using subsurf it seems, the only problem is you get to a high amount to maximize accuracy with 3-5 bounces and you will never actually get to the rendering (it remains at preprocessing AAO)

I’m inclined to believe Brecht will optimize pre-processing time and make it work good with large faces in the next months as may be required by the Durian project.

not that I’ve tested, but how is subsurf not real amount of vertices?

I mean as far as the renderer is concerned it just receives mesh data,
whether there is a modifier on the obj or not… :confused:

You need SVN build of revision higher than 25070… I do not remember exact revision number of official 2.5a0build, though it is lower and at that time AAO color bounce was not yet implemented.

I was unable to really determine how this system worked with the monkey text box BLEND file posted here, but I was able to integrate it into my current working scene and observe the results.
The glowing parts of the space ships are using the emit value with the new AAO feature.

Wow this is really great! I hope that once they add render baking back into 2.5 that the new GI will be bakeable just like the rest of the AAO. That would be epic for video game texture creation or saving on animation rendertimes.

It sure would…crossing my fingers!

Their seems to an interesting problem if an object with reflections is added.

Same file without reflective sphere:

Some light reflection from a mirrored surface makes sense, but this seems more than their should be.

In addition you can see some artifact issues on the back wall. Here is a render with curves edited to bring out the artifact. It might simply be a matter of tweaking some render settings.

It seems that increasing the accuracy via dropping the error values will remove the artifact, but also decreases the color bleeding. Looks like we’ll have to hunt for a sweet spot.

I try render on blender 2.5 but i have errors :

found bundled python: /home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/python
Traceback (most recent call last):
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/python/lib/python3.1/", line 104, in <module>
    import _hashlib
ImportError: cannot open shared object file: No such file or directory

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/scripts/modules/bpy/", line 41, in test_import
    return __import__(module_name)
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/scripts/io/netrender/", line 21, in <module>
    from netrender import model
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/scripts/io/netrender/", line 21, in <module>
    import subprocess, shutil, time, hashlib
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/python/lib/python3.1/", line 135, in <module>
    md5 = __get_builtin_constructor('md5')
  File "/home/Cata/blender-2.5-alpha0-linux-glibc27-i686/.blender/python/lib/python3.1/", line 62, in __get_builtin_constructor
    import _md5
ImportError: No module named _md5
./blender: symbol lookup error: ./blender: undefined symbol: gzopen64

You miss a library, install libssl the way you usually install software on your distribution.

:confused: Right: subsurf over value 4 gets pretty problematic. I often try to combine Subsurf and multires… it works pretty well, most of times (yet have to play around and tweaking the Grease of edges). Slow, but Blender won’t crash easely when rendering.

Hi guys,

Sorry for a silly question, but how do you enable usage of emit in ambient occlusion? I am looking at 2.5beta, based on r31878 - has it been removed (again), or is it hidden somewhere in the configs?

Best regards,

In World Properties, choose Approximate for Gather and Indirect lighting Panel will appear.

Ah, thanks, Zeauro, this is exactly the tip that I needed. It works now. And I can see that it definitely needs further work to be complete (I was expecting a result similar to what radiosity used to do in the earlier Blender versions) :frowning: But as an additional effect - very nice.

Thanks again,

Radiosity used to be a little cumbersome for rendering, however, it rocked for baking the light as vertex colors for using in the game engine.

I loved to have many objects baked into a single shell mesh for game environments, looked very real and was really light on the engine.

If there is no solution for this in 2.5 I will have to keep a 2.49 around forever.

As cool as this is and all; The AAO can’t cast shadows. Radiosity could.

Here’s something I was working on before Blender 2.5 came out.
This is with radiosity:

This is how it comes out in 2.5 with indirect lighting:

Note the lack of shading.

I had to resort to using area lights to get it to look any good:

old thread…

anyway, Cycles is on it’s way and I’m hoping for bake options along with passes and other previously supported stuff.

Cycles does look brilliant indeed!