Blender 2.5 User Preferences Crash !

Blender 2.5 User Preferences freeze !, everytime I open it. My operating system is Windows 7 Ultimate, my Blender version is 2.5 Alpha 2 v2.52.5 r’2889’. Also the terminal output does not say anything about the freeze. This blender was built by myself. Every-time I open it, it crashes, but everything else works fine if I don’t touch/use the user preference. All I am doing is, clicking File -> User Preferences, also pressing the Ctrl + Alt + u shortcut.

A bit more detail might be useful…
What OS are you on? What exactly happens? (does blender just close, or does it freeze?) What build are you using (Alpha 0, Alpha 1, a build from graphicall?), What is the terminal output when it crashes?


How do you know it crashes because of the user prefs?


So… what exactly do you do that makes it freeze?


the exact same thing happens on my acer lap top ( <- I can’t give system specs because am not at home at the moment) it runs windows vista 32 bit serivice pack 2, 1.5GB of ram and one of those intel graphics chips. All builds from graphical all crush when I open the user preference window. Everything usually works okay but this crashes my machine all the time. Its kind of weird because as far as intel graphics chips 2.5x usually works better than 2.49.

This is not been as big a deal for me as I do most of my blending on my linux desktop but I can say the same thing as jennifer happens to me on my laptop.

@Uncle Entity as to what to do to make it freeze, I just open user preference than there is a 2 second stall and than it crashes

i have the same problem

notice: if you acces any other tab quick it won’t crash

Quick, to the bug tracker!

On all Intel Graphics (laptops in general and tablet pc) based PC blender preferences crash , use the menu for view down to select preferences (that icon you select to go to node editor -> dopesheet > etc).

Im currently using this GraphicAll & it does not crash anymore.

interesting, I’ve seen a similar problem with my laptop with intel graphics
for me it doesn’t crash, but when I click “save as default” it does nothing
I have to close the window with the “x” in the upper right corner

This should be required on all systems with an Intel gfx chip:

That it is RAW! lol