Blender 2.50 taxing system when doing nothing

I’ve just built 2.50 from SVN and I’m running it on an Athlon 64x2 6000+ dual core processor.

When I run it and then leave it alone, it maxes one CPU for about 10sec and then it switches and maxes the other for about 10sec. This continues on.

When I load a file and edit it, everything comes to a crawl every few seconds. When I render something it uses both cpu’s at 100% - but the render get’s very slow every 10 sec or so.

When I try to close it it freezes and I have to kill the process.

I’ve run it from the terminal with the -d switch but see nothing weird. I’m not sure why it’s taxing my system like this.

Any ideas?

  1. What platform are you running it on? Windows? Linux? Mac? 32bit? 64 bit?
  2. Are other 2.5 builds giving you the same problems? Have you tried a build from graphicall.org? My latest builds are posted there for linux 64bit and windows 32bit and they are not causing me the issues you explain.
  3. What compiler are you using? GCC? What version?
  4. Are you optimizing the code at all? OpenMP, fastmath, SSE?

Thanks for the response. It was a headsmacking solution. After researching this more, I decided that maybe I should reboot my pc (I run Ubuntu and rarely ever reboot). Turns out that this did the trick. WIthout doing anything else, rebooting seemed to solve all my cpu usage problems. :expressionless:

Thanks again.