Blender 2.58 bug - shape key not working on complex mesh

I can’t manage to make the mirror shape key working

I made a video to show you the bug

https://youtu.be/VLDk44XGB8o

I tested o simple object and is working!
The head has a mirror modifier already applied !

I tried disabling armature and subsurf modifier

Attachments

shape_key-bug.blend (1.19 MB)

It seems your character’s local x-axis goes from front to back. It should go from left to right, since mirroring shape keys happens on the x-axis

is not this the problem
take a look: I switch the x axe and is not working I attached the file

Your model may not be perfectly symetrical.
I got it to work by deleting one half of your model, adding a mirror modifier, applying it and removing doubles. To apply the modifier you’ll have to delete the current shapekeys. When I made a new shapekey after doing this, it mirrored correctly across the X axis.
http://screencast.com/t/pmYXpPRJ3J1B

Attachments

shape_key-bug.blend (177 KB)

weird, because I tried this before I solved the orientation of the axe,… but now it’s working
Thank you!