Blender 2.58 Problem - Object Color Broken in Multi-texture Mode

Hey. Found this bug in an earlier build, but was hoping it was going to get fixed before this point came around - the object color is blank in Multi-texture mode. I believe textures work, though. I’ll submit a bug in the tracker.


Not exactly sure what could have caused this bug - it seems like it would be pretty difficult to break. I suppose I’ll have to stick with 2.57 for now…

i think it is an improved feature. Like from now on you’ll need to add a keyframe to the object colour to make it work on Multi-texture and Tex-Face…
Also 2.58 has anti-aliasing support.:smiley:

Wait, you need to use a keyframe to set the object color? You don’t need a keyframe to set the object color in GLSL mode, which seems like a bug to me. As long as there is a solution, I’m happy, I suppose. Thanks for that info, saga.

But what is the point? I don’t see how this is an improvement: it’s more complicated to do simple stuff, and plus it breaks backward compatibility.

Edit: The diffuse color doesn’t work like before, but the specular color does!

Yeah, I don’t really get it - why change it only for two of the three game modes? GLSL mode displays correctly, but Multi-texture and Texture Face modes don’t, so why the change? It doesn’t help anything - it just complicates matters…

EDIT: I just tried it. Setting the object color normally works for GLSL mode. In Multi-texture mode, you have to have an F-Curve assigned to the color for it to work (press the I-key on the diffuse color). However, the color still doesn’t show up in Texture Face mode. I suppose this is to be expected because there’s no Blender Materials (?) in Texture Face mode, but still… Is there an advantage to this?

It’s a bug.

oh. i see. i misunderstood.

OOOOh, now I understand I got no answer on Simple Questions Answered:

"Hi,

simple questions here, how nice! Please tell me this: I made in Blender 2.4cubes with faces with different colors, visible in the GE.
How to fix this in blender 2.5?

thx!
3dpoiko"

By the way, SolarLUne, I enjoyed your PythonBlender tutorials for blender 2.5!

good luck ev’rybody, 3DPoiko

@Moguri - Thanks for clearing that up. Hope it gets fixed soon.
@3D - Thanks.

Well, for the time being we’ve reverted back to the old (broken) behavior since the “fix” caused to many other problems.

This was the initial bug report: http://projects.blender.org/tracker/index.php?func=detail&aid=25487&group_id=9&atid=306

seems I’ll just continue my project on 2.57…

Key-framing doesn’t always seem to work for me. I still can’t get some of the textures to work right.

Vertex colors also don’t work, which means my current project would need a whole overdo and many more image textures for it to work properly. (Currently I have a collection of laser that are only different by vertex colors, now they are all the same…)
Any fix for this one?

Could it be related to this?
http://projects.blender.org/tracker/index.php?func=detail&aid=27777&group_id=9&atid=498

If so, then the bug appears to be affecting the internal render engine as well, luckily Brecht is back and one of the areas he does fixes in is shading and GLSL.

I don’t think so

This is in multi-texture mode, and not a node texture either:

Start 2.58
Add a cube
Switch to vertex paint, and make a corner black (or red or anything)
Switch to texture viewport
check it is on multi-texture
press play

You will notice that the vertex colors don’t show.

I just downloaded a new build today off of Graphicall and painted vertex colors on a cube.

The vertex colors only do not work if the object doesn’t have a material assigned to it, assign a material and select the ‘vertex color paint’ option and they should show up, vertex colors in GLSL materials work too.

Having a material for each object is good practice anyway, the material options that multitexture mode has even allows you to render your texface assigned textures, and then there’s the fact that the practice of having objects relying solely on texface features without a material is not used much anymore.

And yes, the release of Blender 258a on July 4 solved my problem,
greetings, 3DPoiko

Yeah, the problem appears to be solved, so, I’m using 2.58a now. Sweet.