Blender 2.5x (all) Installs fine - won't run

Any 2.5x build i’ve tried will install fine.
Upon launch, the console comes up, and the interface
starts to load… before anything else I get an error:

:Microsoft Visual C++ Runtime Library
This program has requested the runtime to terminate it in an unusal way."

etc, etc… this happens with ALL the 2.5x builds i’ve tried.

My system can’t be updated any further than it arleady is (software).
There’s nothing left to update.

Win XP Professional
Python 2.7 (self-contained)
Python 3.1 (self-contained) <-- tried with and without
AMD Athlon XP +1700 ~ 1.5 GH
512 MB DRAM
ATI GeForce 5500 FX 256 MB VRAM
all drivers, service packs, lubraries, updates, etc. up to date

absolutely NO beta or non-certified drivers or controllers
tons of drive space

2.49b works wonderfully, however

I notice, that you mention installing blender.
Have you tried just downloading the zip, uncompressing it, and running it from that folder.
Im sure other people here have more knowledge about system stuff, but it may be that something went wrong with the origional install, and this has affected all the subsiquent attempts. Also try deleting your
startup blend located in “user/app data/blender foundation/2.5” folder. Failing that it could well be graphic card problems.

I guess you need VC2008 (SP1) redistributable package form MS