Blender 2.6.2 ...transform>Scale to image ratio

I have been watching a youtube video on uv texture mapping in blender 2.49. i am setting up a blueprint 3 view in blender (top view plane, side view plane, and front view plane). After creating a new material, applying a texture to that material, and displaying it on the top view image plane i have created…the video says i need to go to object>transform>scale to image aspect ratio. This ensures that the image ratio is correctly displayed that im am going to use as my background for modelling.

when i try to find that option in blender 2.6.2 it isnt the same.
i go to object>transform>…err there is no option to scale to image aspect ratio???

can someone tell me how i scale to image aspect ratio in blender 2.6.2???


I would say you’re working overtime. That probably is not said in tutorial for 2.49, but Addon Import Images as Planes does it automagically for you in 2.6. You just need to scale one image compared to another view to get them aligned. Aspect ratio is maintained if you scale not locking to some axis while in orthographic view. Tip: look on Toolshelf for Import Images options to get them properly sized.

If you still need to scale by certain numeric value, that can be input using keyboard as a calculated expression on N-panel Scale fields e.g. for 800x600 px image X “123.034*(800/600)”, Y “166.022*(800/600)”

Alternative to Addon, is using Background Images facility which also is located on N-panel. You can add different images for your views, scale and position them to align properly.

i tried importing images as planes but it doesnt seem to work for me. i cant remember the problem i am having as i gave up on that method very early on ( my memory is so bad, a few days is like a year ago when im learning somethig new). i had no problem activating the images as planes script…there was something else i wasnt doing right. ill look up a newbie tutorial on that script i think as it looks like a real time saver. does it automatically place new image plane in the active view, or does it default to top view? (i ask this because i will import 3 views…top, side and front.)

i eventually went back into gimp and looked at top view.png image…its ratio is 1.109:1 (it was autocropped just in case ur wondering about the weird ratio) went back to n panel amd manually set my background plane ratio accordingly. i then plan on duplicating the top veiw plane, rotating about x axis, creating a new texture of side view.png…and applying that to the new image plane. i reckon ill hafta play with image ratio for each new image plane…but now that i know how to do it manually im ok.

There was a change how images as planes is imported. Now, by defaults, they come in really tiny, so that you can see them added only checking Outliner window. On T-panel, Toolshelf, there are a lot of options available immediately after you click Import and browse folders.

Last section has Plane dimensions - use Dots/BU for old behavior. Another is hit “s 100” while plane is still selected. Helps on most occasions.

I feel it prefers Top view.

ah that worked a treat…scaling it up was the answer!
Also, i forgot to change the view to texture mode so that the plane displays the image instead of a blank box.

thanks a lot, you helped heaps…ill be doing this way in future!

Just one other thing…

how do i get the final scale of the 3d aircraft correct when im ready to export it back out into my simulator? (I need the final 3d model to be set to the following dimensions…Length 33.91 metres, Width 35.05 metres, Height 11.94 metres)

If you have import option available (don’t know what we talk here - “my simulator” doesn’t work ;)), see how your imported objects compare to what you have ready in blender.
Generally, in Scene properties tab (next to Camera icon) you can switch to Metric Units and change your model’s size to what’s needed (Ctrl-a, Apply scale). That might be ‘wrongly’ interpreted by export script, anyways. Then just experiment.