Blender 2.61 - Cycles doesn't work with GPU 1.2 or OpenCL 1.0

Chances are that someone has asked this before, but I cannot find anything on this. Cycles on the CPU are very slow, but I know the GPU is much faster with cycles. I tried using CUDA, but Blender says that 1.3 is required. I have 1.2.

I then tried OpenCL, but that says I need 1.1 or up. I have 1.0.

Is there any way to use my GPU in cycles?

Regular < 1.3 is not supported but you could try to set “Feature Set:” to “Experimental” then it should build the kernel for your card.
If you are on linux you could try the builds from fish on graphicall, he included the older kernels in his builds.


Even with a 1.3 card like me not all cycles features are supported, time to update.

Cheers, mib.

Unfortunately, it looks like Cycles can’t even build the kernel for my card. :’(

Well, I guess it is time for that upgrade. Thanks for the info!

Datawraith-
Download this build from Graphicall: http://www.graphicall.org/444.

Under system preferences, set the compute device to CUDA and save as default:


Then make sure that you have your render settings set to “experimental” and “GPU compute”.

I use this build on my laptop which has a GTX280m- about 3 years old. Works great.