Blender 2.62 viewport shading = ugly (bl 2.49 = NAIS) -- HELP --

Ok so i am starting to use 2.62, never used anything besides 2.49.
And i noticed this annoying effect in the viewport. Some faces are completely black, even if i go in Textured Mode, and this dose not make my job easier when i am working with textures (texture baking results a lot harder to examine :().

Please if someone knows how to disable this shading thing to make it like it was in blender 2.49 please let me know.

Keep the shading to Solid.

Open the 3dview properties (press N in the 3dview) and look for the Display tab. There you can enable ‘Textured Solid’. This will show textures in Solid viewport shading, without the influence of lights.

I tried that, and the same effect occurs, tnx 4 input.

I`ll load some screens as soon as the current render finishes :))

Ok so apparently i had GLSL thing:

  1. switched to Multitexture = same effect but stuff are more brighter
  2. Moved the light source in an empthy layer
    If the layer that has the lightsource and 1 object = that object will get the weird shading effect