Blender 2.63a AVI Codec Quality Issue

Hi guys. I have rendered 10 seconds worth of a video for a test to see how my scene looks. The individual frames look great, but it looks terrible when using the AVI Codec to turn it into a video.

It seems that when there is a lot of movement that there is a lot of graininess/blur going on. It gets somewhat better when the camera stops moving. Any ideas on how to fix this?


Maybe I should rephrase the question. How do I go about getting decent quality video? Is the AVI codec not the best choice to use?

Avi is not a codec so just saying your file is an avi is meaningless, it could be one of many different codecs. Render an animation as a lossless image sequence and then convert this to a video format such as H264 using the render presets in blender or for a generally better result an external application such as virtualdub

Richard is right; AVI is a delivery container. Common misconception, though. It causes a LOT of confusion.

Ah, thanks for clearing that up. That was one of the movie “formats” that Blender said I could use.

I’m trying your suggestion about going to a lossless H264 format. I seem to be having trouble getting the video to work properly that way. All of the frames are rendered, but the video is all black on playback. Is there something that needs installed to create a video in H264 format properly? My guess is that something hasn’t been installed on my computer for this. Thanks.

Blender comes with all codecs included managed from ffmpeg.
May your player cant mamage it, try VLC player >
It has also all codecs on board.
Or load up the video for testing.
Cheers, mib.

Thanks mib2berlin! VLC is the only media player on my computer than can play H264 lossless videos. Now I just need to tweak settings to get everything looking good.

I’ve been using MPEG with H264 for a while with good results, but those choices using recent BuildBot builds now produce very pixelated video. I’ve had to enable the H264 lossless option which solved the problem. I’ve been meaning to go back to an older Blender version to look for what may have changed, and/or spot for a bug.

H.264 is great for preview videos, since quality is decent & gives small file size. Colors however come out lighter & desaturated.

If file size is not an issue, then try QTRLE (set MPEG in Output, Quicktime as Format & QTRLE as Codec). Big file size but great quality.