blender 2.66 doesn't render alpha images.

just trying out the new blender version and tried to create a lens flare composited out of multiple renders, unfortunately when i click on rgba for a png rendered image it renders the background instead of leaving it transparent or have no alpha:mad:. THis is all in Blender internal render engine NOT cycles. Does anyone else have this bug?? or is there a silly little short cut i have missed out. thanks :stuck_out_tongue:

PS i also tried the 8 bit and 16bit color thingy

I’ve been having the same probelm. sorry I cant help:(.

-Thanks

I saw this yesterday maybe it will help

thanks for the effort:D but this is in Blender internal not cycles

I was able to get an alpha layer using the alpha channel from a vector pass

You have to check Transparent in the Film options in the Cycles renderer

I had the same problem in Blender internal render.
Are you saving your picture in RGBA mode? (This is red-green-blue-alpha)
You can choose this in the render panel -> Output.

only replying to this thread for archiving purposes, as i quickly found on a google search. In the Scene render layer properties. Disable the “Sky” checkbox to output to an alpha, otherwise the background will be rendered instead of an alpha channel.