Blender 2.66a and 2.66.6 beta on HP EliteBook 8530W

Hello, I setup Blender 2.66.6 beta on my laptop. Windows 8 x64, Core 2 Duo P8400, 4GB RAM, ATI Radeon HD 3650. (I know, not ideal.) Out of the box it starts up fine, but as soon as I press F12 to render the scene, Blender immediately closes. I then set it to “Windows 7” compatibility mode, and it opens the render window, renders about half of the cube (in a split second), then everything closes. So I tried the 2.66.1 release, and it seems to function normally. I understand ATI GPU’s are not really supported, however in both versions, the CPU is set as the rendering device. Any ideas? Thanks.

I’m assuming the 2.66.6 beta you mentioned is not an official blender build. The most recent official build i know of from blender is the 2.67 RC1 release on their website. Which 2.66.6 build are you using? I’m guessing it’s one from maybe? Knowing which build may help determine the problem.

Also, see if you can get an error message or some idea of why it’s crashing. The default behavior for Blender when you launch it is you’ll usually see a DOS/Console window open for a second or so before the main window loads. The Console window will auto hide itself once blender is running. If you goto the Window menu of the info pane in the main blender and chose “Toggle System Console” it should re-appear.

See if it’s printing out any error messages to the console to give clues to what’s causing the crash.

Alternatively, if the console window disappears before you have time to read any error messages try launching blender from command prompt. That way it won’t vanish and any error messages will still be available to read.

If you need help getting to the command prompt and running blender that way, let me know.

Thanks Powerst. The splash image says it is 2.66.6 r56271, which I thought I’d gotten from the blender website (yesterday) but perhaps clicked some other link. From console-prompt launch, I see “Found bundled python: blah” then “Writing: C:…path to temp folder…\blender.crash.txt”.

Inside that text file, the only entry is “# Blender 2.66 (sub 6), Revision: 56271”.

So I went back to, grabbed the 2.67 RC1, installed it, and found it also is 2.66.6 r56271. So then I ran it, with the exact same results.

Sorry for my confusion on that one. You’re right, the 2.67 RC does show as 2.66.6 that was me not paying attention.

Odd that it’s not writing anything out to the crash log. I glanced through the blender bug tracker and didn’t notice any pending bugs describing your particular problem.

There are some things you can try.

1: Check that you have the latest drivers for your stuff. Sometimes updating the graphics driver can fix things you wouldn’t expect.

2: Try downloading the latest test build from ( for your platform. They’ve fixed quite a few bugs since RC1 was released. I usually update to the latest windows 64 bit build every couple days (I like playing around with new features before they hit release).

3: Try changing the compute device in render. Go into the blender user preferences (Ctrl+Alt+U) and look on the “System” tab. In the bottom device try manually changing the Compute Device there. If it’s CUDA try None, if it’s None try CUDA.

4: Try resetting the user preferences. There may be a corrupt setting in your start up file. In the main blender window go to the File menu and “Load Factory Settings”. If you have a custom start up scene or any special settings you want to keep you can backup your start up configs before resetting in case you need to go back to them. On Windows 8 they’re saved in “C:\Users<Your username>\AppData\Roaming\Blender Foundation\Blender<Version Number>”

5: If all else fails you may have found a bug that no one else has run into yet. Goto the “Blender 2.6 Bug Tracker” over at and post as much about the details of your problem, system specs, and steps you’ve taken. One of the Developers may be able to help you narrow down the problem since you’re getting a crash without any specific error messages.

Sorry I don’t have a specific fix for you. Never seen a crash like this that happens 100% of the time but doesn’t generate any type of error message to clue me into its cause.


Hi Tim. Drivers good; when I downloaded r56506, installed into a separate folder, and ran it, it rendered. So it looks like something was patched in these latest builds. My guess would be a Win8 x64 compatibility issue. Thanks for your help! :slight_smile: