Blender 2.69 Bugs

Hi fellow bge users,
I thought I’d start a Thread on the new 2.69 version of blender to collect new bugs.

I have found a bug in 2.69.0 r60761 RC2 (Windows XP 32Bit) which causes en error when I try to export the game as runtime.
This also happens with the “Default Cube” - Scene.

Haven’t found anything related in the bugtracker yet.

Can someone reproduce this?


Attachments


Can’t reproduce that, on osx… For me it seems more like a path issue.

I checked this with both .blend + export folder under

  • My Documents
  • D:\ (root folder)

Both don’t work.

A test with with 2.68a on that locations worked fine.

I think this was mentioned a few days ago. From memory there is an error in the export script (fairly obvious given that error!), where it looks for the blend with an extra .blend on it. There was a fix for it, but I can’t remember what it was. I’ll hunt through tomorrow and see if I can find where it was mentioned.

A couple of bugs to report.

The most serious bug is if you zoom out too far you can’t get back with the Zoom in. I Stretched a plane too far and now I can’t get back to view my model! Zoom in poops out and Home doesn’t work either even with the offending plane deleted. (UPDATE: when I restarted Blender the Home key worked this time – whew!)

On that point if one could add a hotkey to Home in on Selected objects that would be dandy – perhaps Shift Home?

The other bug is Blender crashes if one’s system is not quite adequate and one tries to activate Dynamic Topology. Luckily I had saved recently as Blender just vanished.

Otherwise Blender runs well on the older laptop I am currently forced to utilize.

Gary Goodman

View selected use the numpad . key

Report bugs to the bug tracker (link in blender help menu). Just posting on some internet forum will not get them fixed.

When I was stuck I did try the NUMkeys – no go. Best I figure is I exceeded the CG space available in Blender.

Doubt it

Here is a 1,000,000 km cube


You guys can run the blend file using the blenderplayer , no need to pack it as an exe. Put your blend file where blenderplayer is and then create a .bat file that has something like this in it:

start /LOW BLENDERPLAYER -f “your_blend_file_name.blend”

Lamp instancing is not working. I tried to add tail lights and headlights to all these cars and it’s not doing it for some odd reason. LOL

Attachments

City 002.blend (1.06 MB)

I created a bug report on the “save as engine runtime” issue:
[#37157] save as runtime: File Not Found (*.exe.blend)

should have checked a buildbot or waited first wendigo that bug was fixed in trunk 3 4 days ago. seen this particular one pop up before in previous rc releases I think.

in <blenderpath>\2.69\scripts\addons\game_engine_save_as_runtime.py in function WriteRuntime move blend_path += ‘.blend’ before bpy.ops.wm.save_as_mainfile(filepath=blend_path, relative_remap=False,
compress=False,
copy=True,
)

I’m not sure what went wrong there but adding spotlights seems to work just fine.

Attachments

Add_spotlight.blend (84.7 KB)

If you’re using multitexture mode, the lamps may have been added, but they wouldn’t be producing any light if you already hit the limit of 8 active lamps in the scene.

GLSL mode in contrast will allow as many lamps as your GPU supports, but it might slow down the game if you insist on making all emission surfaces cast real light as opposed to just having an emission map with a glow filter.

I got the same error !!! :frowning:


even with simple rotating cube… while in Blender 2.68 it works well …

Is it 2.69 final?

I get it from blender.org so I think its final.