Blender 2.6a Problem with rotation of viewport

I cant rotate the viewport via the middle mouse button like I used to…it used to allow me to rotate upwards as well, like this -----
and also
1
1
1
but it wont let me rotate upwards diagonally and it keeps the ‘grid’ flat to my viewport at all times…I really liked the freedom of movement from 2.59 and now I dont have it>? how do i change this back?

also this ‘freedom’ is in all blender versions since 2.5.0

Change the orbit style in your preferences from turntable to trackball.

mmk i will try it thank you

OMG! THANK YOU SO MUCH! I can finally rotate correctly…thank goodness it wasnt a bug :smiley:

Hi!
I’m having the same problem with rotation. I tried changing the orbit style in User Preferences to Trackball with no apparent difference. I’m using a mac os x 10.5.8 with a touchpad. Any suggestions?

I don’t know if it can be applied to your case as i don’t have a touchpad, but i sometime got such problem when using a new build of Blender, and going to File -> User Preferences -> Input tab -> Enabling then Disabling the “Emulate 3 buttons mouse” was enough to give me back the mousewheel control to zoom in/out

Brilliant! Actually, all I did was enable “Emulate 3 button mouse”, then “Save as default” and it works a charm! Thank you so much!