blender 2.71 not running on ubuntu 14.04

Hello everyone,

I have just finished building a computer for running blender. This is the first one I’ve ever done. I decided to install Linux instead of Windows and I heard good things about Ubuntu. I just installed it yesterday off the official Ubuntu website and installed it with no problems.:smiley: It is Ubuntu 14.04.1 Desktop AMD64 64-bit. Then I downloaded Blender 2.71 64-bit from Blender.org. My computer isn’t connected to the internet so I had to download it on my phone, then transfer it to my computer. I have installed Blender twice on Windows XP systems this way with no problems before. Everything I read said all you have to do on Linux is unzip Blender into the folder of your choice. I opened the zip with Archive Manager or something like that and extracted it to home\Program Files\Blender3D.





Then I tried clicking on the Blender file, double clicking on it, and eventually found someone that suggested opening it from the terminal like so

    $ ./blender

Nothing worked and the terminal returned the error message:
Error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file no such object or directory



I double checked that I was in fact running 64-bit stuffs and yes blender and ubuntu are. I downloaded the blender zip file three times, two 64-bit and one 32-bit just in case the file didn’t download properly.
I ask a new Linux user and only know what I have picked up while messing around with it for the last few hours. I may have not completed an installment step, or am not extracting it correctly. I really don’t know. I have tried restarting my computer several times and that didn’t help.

Also, I found this guy ruining into the exact same problem with the same software and he resolved it but I’m confused as to what he did exactly.
http://ubuntuforums.org/showthread.php?t=2233517

Thank you for your time and any suggestions are welcome, no matter how “obvious”.

You need some some support libraries to run Blender. As the terminal output says, it can’t find libSDL-1.2.so.0

The easiest way to fix this is to install Blender from the Ubuntu repository. It will be an older version, but it will automatically install all the required dependencies. Then you can run the downloaded Blender 2.71.

You can subsequently remove the older version if you want to, though it won’t do any harm to leave it installed.

Ok, can I do that without my computer hooked up to the internet? Like I said, my computer had no internet connection so all my downloading had to go through my phone first. So that obviously make things difficult when the installer needs to download stuff directly then install. So can I get the necessary files on my phone, then transfer them to my computer? Otherwise I may have to lug the whole tower down to the public library to get it online :slight_smile:

Hmmm. You can, but you will need to know which ones are required. :slight_smile:

It’s ironic that most of the solutions seem to require first installing something else. I couldn’t make this one work, but I already have all the files installed, so it was probably listing none because I need none:- http://askubuntu.com/questions/306971/install-package-along-with-all-the-dependencies-offline

I remember doing this once myself with a usb stick. You can use the Synaptic package manager to generate a download script. Though if I remember rightly, synaptic isn’t installed by default anymore :confused:
https://help.ubuntu.com/community/Synaptic/PackageDownloadScript

Alternatives are this:- http://askubuntu.com/questions/974/how-can-i-install-software-or-packages-without-internet-offline

…and packages.ubuntu.com lists dependencies for individual packages:- http://packages.ubuntu.com/trusty/blender

So, initially it looks like you are missing at least libsdl1.2debian though of course, dependencies also have dependencies.

EDIT - You can access those links on your phone, can’t you ? :slight_smile:

I used your last link, installed the 64-but version at the bottom of the page, transferred out to my computer and then installed it with ubuntu software center. Now blender works perfectly. Thank you so much organic!