blender 2.74 doesnt work

Hello people!!
I have a wierd problem, I just finish building my pc, it has

MotherBoard: Gigabyte 990fx
CPU: AMD fx 8320
ram 8gb
Graphic card: Nvidia GeForce GTX 960 2gb
Power: sentey 650w
watercooling corsair h80i.

Well after installing Windows 7 64bits and installing all drivers
and actualizing them, i go to install Blender 2.74, but it just
doesnt open, after it compiles and it closes. It Dont even show
the presentation window.
I tried older versions like 2.70 and it works, but wont render
with gpu, it says ¨Error, CUDA binary kernel for this graphics card compute capability 5.2 not found¨

i tried downloading blender zip, copying the files \scripts\addons\cycles\lib But still doesnt work,

And i really need it. I hope you can help me. thanks a lot.

Here a video for the CUDA problem.

Ensure you have installed the Visual C++ 2013 redistributable package from

For the GTX 9xx graphic cards you need to use blender 2.73 or later

Some user have problems to start because missing service pack 1 for Windows 7.

Cheers, mib


you can use this release :

it’s ok for me :wink:

but why the official version does not ?

thanks i did tried it, but nothing happened!! :frowning:

yes i have it, i installed it again, just in case, but still with the same problem. Now im kind of thinking if its just a system problem or my graphics card isnt compatible with my mother, but i checked very well after buying it, besides, im using sony vegas and premier and its working just fine. so i really dont know.

Hi, there are some reports here and in bug tracker and all could be solved with a full updated Windows 7.
Service Pack 1 + all updates and, as Richard mention, Visual C++ 2013 redistributable package.
You can also try to start Blender from a Command Shell (CMD) with “blender.exe --factory-startup” without quotes.
Blender does not start with a corrupt startup file and the file is not overwritten during new install Blender.
You get also error messages in CMD.

Cheers, mib