Blender 2.77 not the same render colour as 2.78?

Hi all,

As an Indie musician , producer, I recently started to work with blender to create animations as video clips for my music.
I started working in Blender 2.77 and today I thought Let’s try the RC version of Blender, 2.78. (I used to be an Informatics guy, so love to try out & test betas)
All is well, same project (even using the same preferences etc.) In material view all is OK, but when I render a frame, there is a big difference in colours on the model under the spotlight (see pictures)!?!

Am I missing something here!? Can someone confirm?



(p.s : Sorry if this is not at it’s place here, but didn’t see where else to place this question)

Thanks you community :wink:

Are you missing a texture ?

File / External Data / Report Missing Files

Check Outliner for visibility/render of caterpillar mesh(es)?

A short explanation of Richard’s question, since you are new to Blender – if a texture used in a material/shader is missing (meaning somewhere Blender cannot find it), Blender will use a flat 100% magenta hue instead (bright pink). Your green turned pink is a clue that the new Blender version cannot locate a texture file used in your caterpillar skin shader.

No really! exactly same project (opened up in both versions at same time)

Thanks Richard, Eppo & Chipmasque!
I checked it again (well to the extend I’m able to understand what I’m doing of course…lol), but don’t see anything strange, missing or different? (include some screenshots of materials and identical nodes?!)
No problem guys, it was just an approach to test my project in the new CR 2.78. I’m afraid it’s beyond my skill level to dig into it deeper; All is working fine in 2.77a. Thanks anyway for your help and suggestions.




Open an image editor window. On the header you will be able to select a texture from the drop down list. Open the texture used in this material. If you get a blank screen you are missing the texture and so get the magenta colour.

Easiest fix. Open the file in 2.77 so it looks ok. Pack texture into the blend file with File / External Data / Pack all into .blend. Then save your file and the textures will be available in any version of blender

Thanks Richard and the others,

I checked all the images if there where lost textures and found some in another (obsolete) scene. Deleted them by shift clicking x and reopening the blender file. Although they had nothing to do with the caterpillar, but you never know :wink:
Nothing still the same!!

BUT it turned out to be ,what I think is a bug or well ment feature difference in between the versions, the RGB Curves node doesn’t behave the same in both versions!!?? I get the same colour (with the right texture) back in 2.78 after bringing down the ‘fac’ from 1 to around 0.5 ?!

Oh well to be sure I continue to render my latest scene in 2.77a, just to be sure to have no colour shifts in the animation. New scenes will be done in 2.78 :wink:

Thank you all for your quick responses and insides! much appreciated.

LuLu M

My opinion is that if you have the same scene in the same machine/system and you get different results with those versions of Blender, is at least suspect about why one is not finding those textures. Just in case check that this is not due to different configurations in Auto Run Python Scripts between versions.
My advice is to report the problem just in case.
You remember that you must to share a .blend file where developers may try to reproduce the problem.
https://developer.blender.org/

Edit:
I think you should share with developers the problematic scene with packed textures and the same but without packed textures.

Yes YAFU, I’ll do that, as I do think like you, both versions should give up the same result on the same blender file with included textures (option add textures automatically activated in file menu)!

After I did some more testes, with the little experiences I have with blender, I noticed that the whole ‘purple haze’ was gone in 2.78 after I deactivated the ‘Open Shading Language’ option in the render properties!!! Don’t really know why it was activated in the first place and what it does, as it slows down my rendering (don’t have a dedicated graphic card, just an i7 4790 for the moment).
So it seems that when this option is turned on in Blender 2.77a, no ‘Purple Haze’ like in 2.78. When this option is off, all is OK in both versions!!!

That’s it for me, I can carry on, sorry about all the fuzz…, Just wanted to understand as I really start to like this program very much :wink: