Blender 2.77 RC1

Hi, Blender Foundation has release first RC build of Blender 2.77.
There are a lot of new features included.

Check out:

http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77

http://download.blender.org/release/Blender2.77/

Please report bugs to https://developer.blender.org/maniphest/project/2/type/Bug/
Use the template and add all information you can get and attach a simple as possible .blend when needed.

Have fun, mib

Also, when it comes to bugs. Keep in mind that this may be your last chance to report the bugs that are bothering you before the official release.

Heck, go ahead and report every quirk you find if you can prove in your own tests that it is probably a genuine bug (and not something like a missing feature or a limitation).

Copy previous settings is just hanging blender, have to kill it on win 10 64 bit, is anyone else getting the same ?

edit worked the 3rd time i’d deleted the folder it creates in roaming, just seen my old folder is 9 gig, think I just have to wait, the first failed attempt only had 3 gig in it. takes ~30 secs to set it up

Saying that it didnt do it with the previous test build but I think that was using my existing profile not creating a new one

You had cache files in your config directory. They shouldn’t be there.

Dudes, there is a button on the splash screen to use the old settings, just click it!

Ahh how did they get there :slight_smile: thanks, Will keep an eye on where they are writing in the future, all my point density particle cloud stuff was there, that would do it!

Hi Umii, you have Cache BVH checked in Performance settings.
This feature is kicked in 2.77 so never GB´s on disk again (except Smoke).

Cheers, mib

@Umii

yeah it hangs, but it works in the end so… yeah

hmm

amd 390x


Totally broken with amd graphics. Glass becomes glossy for some reason.

Edit: I removed the glass shader and combined glossy with refraction, and transparency. Works now. Even transparent shadows work. Even 3 seconds faster render. 47.5 seconds benchmark.


Maybe glass shader is just broken?

Edit. Transparent shadow doesn’t work with lamp.
Edit. Lamp shadows work with experimental.

Hi gang, previous settings loaded for me ok on win 10. Not sure about the splash. Might have to switch it off until 2.78/9.:eek:

Edit
(GLSL Anti alias seems to have gone to crap in the view port with this build, but my driver needs an update. Im on 355.82 atm.)

Scrub that. Updated to 361.91 and ok now. Some weird driver problem, that only showed with this build.

Ha , thanks rebogey! :wink:

Hi All,

I used this build as my main all weekend, some great improvements, I did have ~5 crash to desktop on windows 10 every time when I did ctl Z to undo an operation. I was mainly rigging/weight painting. I tried to recreate by repeating the action and undoing but it always worked the second time, so I don’t have anything sensible for a bug report to recreate.

Does blender dump a stack trace or anything like that when it crashes, it did trigger the windows looking for a solution popup so it must have dumped some information. Any ideas where I could look to get additional info to make a more meaningful report ? Will obviously included my full system specs etc.

Usually blender pretty rock solid for me so I forget to save regularly :slight_smile:

Mmm, I had a similar crash when ctrl+z but I was using the Hard Ops add-on and just thought it was that. So far ctrl+z hasn’t crashed blender.

The Environment texture node has an option to choose the texture interpolation now.

What does this mean?

It’s the same as this: http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.71/Cycles#Nodes (see the image on the right), but for the Environment Texture node.

Fire now renders on GPU!!!
Thank you, blender devs!!!

Hi i command CYCLES_OPENCL_TEST=all don’t work in 2.77 RC1, in 2.76b works fine and is very fast.

GPU works in 2.76b, command “export CYCLES_OPENCL_TEST=all” make it totaly fast, but in 2.77 RC1 command “export CYCLES_OPENCL_TEST=all” doesnt work.

GPU works in 2.76b but command export CYCLES_OPENCL_TEST=all is totaly fast. Its shame that tis commnad doesn’t work in 2.77 RC1.

[ATTACH=CONFIG]425888[/ATTACH][ATTACH=CONFIG]425889[/ATTACH]