blender 2.77a mesh selection highlight unexpected behaviour


I use Blender 2.77a on Fedora 24 and a laptop that is older than my deceased grandmother, if that info is relevant.

I’ve encountered a problem with mesh display recently. When I select edges in vertex select mode, Blender highlights the selection weirdly. Instead of fully highlighting selected edges + drawing a fall-off highlights on edges that are connected to selected vertices, it fully highlights some random adjacent edges as well as selected ones.
Here’s the screen recording of that behaviour that I made (31 sec).

Selection highlights work correctly when the mesh is set to smooth shading, but do as described above when switched to wireframe display (I forgot to include this in the video).

And also while recording I noticed, that smooth shading is applied to mesh only when it is selected, so when I select something else - the mesh appears flat shaded and triangulated.

I thought the cause might be that I launch Blender from an executable in the unpacked tarball (from the official blender download), instead of installing the software on the system. So I properly installed the same version of Blender with the package manager, but the problem persists. Thought it is not a critical problem, it is still very annoying.

Has anybody else encountered similar issues?
It doesn’t look like some lost checkbox I don’t know about - it looks more like a bug, but I thought I should post that here on blenderartists before sending a bug report.

Hm interesting. I don’t have the same problem as described but I would assume it is some kind of bug. Did it do this on the older version of Blender? Also did you make sure to download the correct version of Blender for your specific computer specs?

My guess is video driver. I’ve got an NVIDIA card on Linux Mint, and the default nouveau driver does that same sort of thing. It’s solved with the proprietary NVIDIA. Take a look at what your other driver options might be.

Could test and see if it’s the gpu/driver or not. Blender comes with blender-softwaregl script which launches Blender without hardware acceleration. If it works as it should, it’s the gpu/drivers.

Thanks for your answers, everybody.

This problem for sure didn’t appear at least with 2.76 and before.
I wasn’t aware that there were a lot of versions of Blender for various computer specs, but I’m sure I have the correct one for my operating system - I believe I wouldn’t be able to launch it otherwise.

SkpFX, JA12
Yep, you are right about gpu/driver.
Thanks for pointing out to the blender-softwaregl script, JA12. I launched blender via the script and mesh display works just fine.

Didn’t expect driver issues to appear on Linux, as everything was always working right out of the box, and especially I didn’t expect them with Blender, but here they are. But then again, my GPU is

Again, thanks for your answers guys. I wasn’t even able to compose a google query for the issue.