Blender 2.79 or earlier won't open, after using 2.8 beta (SOLVED)

I used the beta happily the past few days, but a bug prevents me using it to render the finished work.

OK, no prob, I close it and open good old 2.79… but it won’t. The icon bounces in the dock a few times, and the Mac even switches to the separate workspace (like it should) as if blender is open, but, in a split second, it’s gone. I never see the blender interface appear. Just a few bounces and… nothing.

So, I’m working from the hypothesis that using the 2.8 beta caused this… and I’m searching my Mac for preferences to delete. I can’t find any. Where, if they exist, are pref files or config files that might be affecting these old blenders, keeping them from starting up?

I also tried trashing the folder with the 2.8 beta in it. Nope, same result. Only the beta will open. Earlier versions will not.

There is hidden stuff created in your user folder. Try trashing both apps using Appcleaner. Thats the only way I managed to fix this when it happened to me. It will find ANYTHING on your mac to do with the blender application. Just tick all the boxes and try again…

I have run 2.8 and 2.79 and 2.79 nightly happily by putting them in seperate folders in the applications folder


I think this way the hidden stuff gets create separately, rather then 2.8 and 2.79 sharing the hidden data that it needs, like your saved prefs etc. I think 2.8 has updated your user settings beyond what 2.79 is expecting, causing it to crash, since they are reading these settings from the same place.

You are aware of the fact, that there is no backward compatibility for files saved in 2.80, aren’t you?

Due to the way layers and scenes are handled now, there have been significant changes to the file format. For all intents and purposes 2.79 is not forward compatible with files made with 2.8. Maybe (and that’s a very tentative maybe) some kind of limited importer for the new .blend files will be retrofitted into the eventual 2.79c, but I wouldn’t count on it.

The fine print on the download page (now unwisely hidden till you click on Legend for some reason) did warn you the beta is for testing only and not to use it for production.

Yes, I’m aware that beta files aren’t backwards-compatible. Not a problem. I never expect that from a 3D app anyway.

But not being able to open 2.79 at all was a problem. I solved it. I used Time Machine to restore the files I found in /Users/(me)/Library/Application Support/Blender/2.79 with a version from before I installed the beta.

Each blender version I have is in its own separate folder, though not an extra folder layer deep like jimbobrjames. Nonetheless, using the beta and tweaking its preferences caused something to change that affects the old blenders, too.

It happened again. The beta changed the files in the release version’s config folder.

It doesn’t matter what folder the beta is kept in. It overwrites files in my release version’s “2.79” folder in /Users/wellerankanto/Library/Application Support/Blender/2.79

This is so weird because, even though I restored those support files from as far back as May 2017, it still won’t work.

If I delete the ‘userpref.blend’ and ‘startup.blend’, then 2.79 will open.

If I put any older version of those files back, I get the same crash.

It seems that something else changed, in some other folder, that I haven’t found, because blender doesn’t seem to care what I put in its Application Support folder. If those 2 .blends are in there, then 2.79 won’t start.

I tried many backed up versions, from yesterday, to days before I ever installed the beta, all the way back to May 2017.

Only deleting those 2 .blends makes a difference.

Also, I found that deleting the 2.80 folder from Application Support folder has no effect on this issue.

BTW, the beta is running out of my downloads folder.


I’ve got same problem. Everything was fine until I downloaded the 2.82 zip. If I want to run any blender I have to delete there userpref.blend and the startup.blend file. Oh and turn off Load UI.