Blender 2.8.20 2.8.3, 2.9 - Hair Doesn't Render With Eevee when STRIP is on

Blender 2.8.3 Hair Doesn’t Render With Eevee when STRIP is on
image

No preview, no rendering. I’ve tried 2.8.2, 2.8.3, and 2.9, the same problem. It only renders when I switch to STRAND, but it’s of no use since all hair width information is lost.

The same hair renders fine in Blender 2.8.0. I’m on Windows 10 and I recently chatted with somebody who doesn’t have any problems with B 2.8.3, but he is on Linux.

This is really weird. I’ve been searching for weeks and cannot find anything. Any thoughts?
I like 2.8.3 and 2.9, but this hair problem makes me go back to 2.8 every time I need to render hair.

1 Like

OK guys, if you ever get this problem, I figured it out. It was my AMD video card. I’ve downloaded the latest drivers, and it renders fine now.

2 Likes

I have an Nvidia card and this was happening to me too. Realized that it had nothing to do with my graphics card but the ‘Diameter of root’ & scale setting in the hair shape panel. Increased it and it’s rendering the strip hair.
Putting it here just in case someone has the same issue.

I have a plane with a simple hair particle and hair does not show on view port. It only shows when I go to PARTICLE EDIT…or if I go to WIREFRAME mode, otherwise the hair is not shown neither rendering. I check same file in 2.83.4 and works perfect. This problem is just in Blender 2.9. Is it just me? Or am I missing out some new strange setting introduced in 2.9 ? :blush:

1 Like

No doubt there is a glitch in 2.9, hair is not rendering or showing in Eevee. I can only see it in wireframe mode. Same file launched in 2.83.4 and it works nicely. I can render the hair in cycles but it can not been seen in the viewport…it displays a few weird triangles that seems to extend to the infinite. Hope it get solved in newer updates.

1 Like

Yes,. I also facing this issue. In Blender 2.9. When I add hair particle it extends to infinite… It should get fixed I was worried that it’s my hardware problem. They should fix this issue…

Problem continues in 2.90.1…no hair in Eevee :frowning:

Could you explain how you updated the drivers? Im kinda new to windows, been on osx for 17 years. I only get black hairs no matter what i do, tried strand and strip and both render black. Test using simple hair material. Tested both Hair BSDF and Principle Hair BSDF.

Im using Ryzen 7 with 1660Ti

EDIT
ow i see, hair shader isnt supported in EEVEE