Blender 2.8 Alpha Mask and Preserve UVs for Foliage

Hey Guys,

i just started learning Blender 2.8. I would like to create some lowpoly foliage for my game but i can´t get the Alpha Mask to work. Im using the “Principted BSDF” Shader, with an Image Texture input under “Alpha”. Under Settings i tried all Blend Mods. But i cant get rid of the Background. The Alpha Mask is a black/white texture, white for the leaves, black for the background.

The other thing is, is there some kind of “preserve uvs” like in 3dsmax?
This means that the UVs are not getting distorted while moving vertices. So i can polish the transformation of the vertices to be as close as possible to the leaf (Less use of opacity, better performance ingame)
Here you can see on a .gif what i mean. With activated “preserve uvs” the texture will not get affected when moving vertices.

Thank you,

And here is my material:

(I replied to this thread, because as new user only 1 picture is possible in a thread)

Thank you!

Try Texture Lock, haven’t tested it out in 2.8 but it was somewhat buggy still in 2.79C but I could get my job done with it.

Also free BlackBeery leafs you want em, high poly models. Black_Berry_Leafs.blend (2.8 MB)

Not sure if im doing it correct. But when i select all faces of the leaf, right click on it ->UV unwrap faces, preserve UVs and then choose the albedo texture, nothing happens.

When i move the vertices of the leaf, the texture still gets distorted :frowning:

Sorry it was texture lock which doesnt really make sense I edited that already to my first message.

Here is video

TextureLock works, not perfect (The texture is shaking while moving the vertex) but it works.
I hope that there is something better very soon. In Max it´s really just one click on the preserve UVs button.

Any idea why the Alpha is not working?

Down on the bottom of your shader, there is a selection for Settings…and under that is Blend Mode…set that to Alpha Blend…That is needed. You didn’t “show us your Nodes” but for an alpha mask, I use a mix shader, a transparency shader, and an alpha mask … a node tree I use constantly looks something like this…

Thanks @RSEhlers, yeah it seams that we need that Transparent BSFD and Mix Shader Node to make the Alpha Mask work. Im actually a fan of the simple material editor. I dont like nodes :smiley:
I rebuilded the material now from a tutorial and now it works. Thanks Guys!

1 Like

Would be easier to check if you shared the leaf with materials and packed textures in this case.
I have no apparent problem using the alpha input of principled, but I have a different format; color and black and white mask image. Worked in Cycles and Eevee, I used alpha mask though in Eevee.

So i must say that everything worked out great.
Here is the game-ready nettle:

Thanks guys!

1 Like

Nice work man. I hate doing plants myself its just tedious did you get textures from CG or took photos yourself ?

1 Like

Thanks Vesa. I have a Megascans Subscription.
I used the textures from it. But i created the complete LowPoly by myself. So i only used the flat textures, no Geometry.

Looks Great…!!!

1 Like