Blender 2.8 Beta - disabling pie menu on z key press

blender2-80

(Andrej Petelin) #1

Hi! I’m new to this forum!

I’ve been using Blender for a good few years now, starting with 2.49. One of the keys I use a lot is the z key to toggle between solid and wireframe views. In Blender 2.8 hitting the z key pops up a pie menu. Seeing as I really want to toggle between wireframe and solid 99.9% of the time I find the pie menu to be intrusive and counterproductive. I’ve tried to disable it via Preferences->Addons, but that doesn’t seem to do anything.

Any ideas?

Thanks in advance.


(Vitaliy Sokol) #2

Wait, I just downloaded 2.8 and loaded Blender 27xx settings at start, the Z key is working as before.

But.
The main idea is to build 2.8 as an addon to blender 2.79 to use only EEVEE engine.
I didn’t even know about they disabled “Z” key.
Interface in 2.8 is a Nightmare to me, but I think it inherits all the keyMapping functions in User Preferences, so may be u could change it there.

PS: it’s glitchy and my test scene was terminated after 2 minuts of use.


(Andrej Petelin) #4

The Z key is still working as it used to, but the problem is it pops up one of those pie menus. As I don’t need to select the view (If I want to see the model rendered I can go click on a button or whatever) to be rendered during modelling I find this an annoyance that only slows me down.

And while it’s, or at least it used to be, an add-on it now seems to be on by default, and I can’t find a way to disable it.


(Vitaliy Sokol) #5

Hmm it didn’t show up any pie menus to me. I don’t see any.
PS: cycles is terribly slow =((((((( 10 times slower than in 2.79


(Andrej Petelin) #6

Oh, I see! Perhaps I should just download the latest build, maybe it’s just a bug.

Re Cycles, that may be a matter of settings, but it does seem as though they’re not quite there yet. I can’t believe their default render engine doesn’t support baking textures and normal maps :open_mouth:


(Vitaliy Sokol) #7

Yep, it was because I didn’t check my CUDA settings. Now it works fine and much faster.


(Andrej Petelin) #8

So it turns out that the pie menus add-on isn’t really needed for the pie menus to actually pop up. The way to disable them is, indeed, as @Vitaliy_Sokol said, to revert to Blender 2.7x settings.

Alternatively, you can disable it in Preferences -> 3D View -> 3D View (Global) -> Call Pie Menu. Note that you have to look for the one with Z as key binding seeing as there’s a bunch of pie menus and their key bindings are all called Call Pie Menu.


(cgCody) #9

I know you turned off the menu and the settings and all is well, but I just discovered a little trick you may find useful.

I like the shading pie menu, but I found myself kinda missing the simplicity of pressing z without having to select something from a menu. In fact, you can have the best of both worlds. If you flick your mouse left WHILE pressing z, it will instantly go to wireframe mode. Flick to the right while pressing z for shaded, and up/down for rendered/lookdev. No need to press z, then click on an option. Just z+flick. :slight_smile:


(Andrej Petelin) #10

Thanks, I did notice that. I also found that the old functionality of Z - toggling between wireframe and solid - had merely been moved to Shift + Z.