Blender 2.8 Freestyle Issue -- Is rendering a freestyle layer but shows behind final

Female_CartoonyProportion_Base.blend (4.1 MB)

Blender 2.8 Freestyle Issue – Is rendering a freestyle layer, but does not display in “combined” layer.
I’m also unable to get it to show up in cycles.
It does render a freestyle layer, Combined + Depth + Freestyle – and I can switch to view it independently, but it doesn’t appear in a render, or render in viewport. I do have a camera.


By default, Freestyle Lines are displayed above Cycles render in Combined pass.
But when you enable As Render Pass option, in Freestyle panel, in View Layer properties : that is intended behavior to obtain a separated Freestyle pass usable in Compositing Workspace.

You can disable As Render Pass option.
Or in Compositing Workspace, you have to enable Use Nodes checkbox and mix Combined pass and Freestyle pass using an alphaover or a mix node.

2 Likes

I swear I checked and unchecked every single one of those rendering options, while attempting to figure it out myself, but apparently not. Unchecking “As Render Pass” got it to work in Cycles + Eevee. Thank you very much.

I have no doubt you did.
You certainly took time to check Render properties tab.
Problem is just that option is in View Layer properties tab. And it is new. It was introduced in 2.83.

1 Like