Blender 2.8 God Rays Volumetric Lighting Offset Shadows

Hi, I personally don’t like the term “God Rays” but it seems to be an accepted and universally used term in CG circles.

My render has shadows that are offset… anyone know how to fix this?

Here is my 2.8 blend file:
light_rays_v4_128.blend (680.7 KB)

These are the areas of the shadow that I’d like to fix

That is a known problem. in Render Tab > Shadows, you enable “Soft Shadows”. And in lamp settings, you try to use Softness value as low as you can.
Shadow quality with Soft Shadows depends on Sampling values in Render Tab.

1 Like

Try using VSM instead of ESM and enable high bitdepth.

1 Like

Thank you! This helped but still left some strange gaps

which I fixed with “Bleed Bias” in the lamp settings… thank you YAFU!